Bug 485891 - NetworkManager fails to connect to wireless and fails to fall back to wired network
NetworkManager fails to connect to wireless and fails to fall back to wired n...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-17 04:40 EST by Gerard Fernandes
Modified: 2009-02-19 14:29 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-19 12:22:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log for the 16th Feb (819.09 KB, text/plain)
2009-02-17 04:54 EST, Gerard Fernandes
no flags Details

  None (edit)
Description Gerard Fernandes 2009-02-17 04:40:08 EST
Description of problem: NetworkManager fails to connect to wireless and fails to fall back to wired network
Acer laptop model: TravelMate 4000
Wireless NIC: Intel 2200 (driver: ipw2200)


Version-Release number of selected component (if applicable): Latest updated Fedora 10


How reproducible: Always


Steps to Reproduce:
1. Update system (around 19:30 BST), switch off system after updates, watch some TV
2. Try connecting again later - doesn't connect anymore. NetworkManager seems to be sending the incorrect WPA2 password! Check in NetworkManager (Edit Connections...) and my wireless network (auto/default) has the wrong key!!!
3. Try to connect directly to LinkSys WRT54GS with eth cable, NetworkManager doesn't show a wired connection for use
4. Delete all wireless connections, delete all keys from SeaHorse (which seems to have to wrong key too for some reason), restart computer.
5. Try connecting afresh - NetworkManager detects my wireless network and asks for password. I set it to WPA/WPA2 PSK and enter my password. NetworkManager tries connecting for ages then gives up. I check the password (Edit Connections.../Wireless tab) and it has the wrong password again!!! Where is it getting the wrong password from?
  
Actual results: No network connection works


Expected results: Wireless network should work, failing which, NetworkManager should most certainly at least be able to fall back to a wired network when connected directly to the router with an ethernet cable.

This is critical - NetworkManager should ALWAYS be able to fallback to a wired network interface, even when any updates may have caused the wireless part of it to fail. NetworkManager running when broken this badly affects all GUI apps - nothing can connect to the internet (even when the wired interface is brought up manually) simply because all GUI programs think there is no network because NetworkManager is telling them so.


Additional info:
Work-around:
1. Disable NetworkManager (System/Administration/Services) - turn it off in all run-levels just to be sure.
2. Stop NetworkManager (System/Administration/Services).
3. Bring up wired ethernet interface manually (System/Administration/Network).
Observe that all works now. Very inconvenient and ties me up to within a few feet of the router, but at least it works.
Comment 1 Gerard Fernandes 2009-02-17 04:47:41 EST
Note:

1. I'm running the LinkSys WRT54GS router in G-mode only and with WPA-2 PSK.
2. Everything was working ok until some updates were installed yesterday (16th Feb 2009) evening by PackageKit.
Comment 2 Gerard Fernandes 2009-02-17 04:48:58 EST
logs
=======================================================================
Feb 15 11:14:09 achiles kernel: input: Lid Switch as /devices/LNXSYSTM:00/device:00/PNP0C0D:00/input/input1
Feb 15 11:14:09 achiles kernel: ACPI: Lid Switch [LID]
Feb 15 11:14:09 achiles kernel: input: Sleep Button (CM) as /devices/LNXSYSTM:00/device:00/PNP0C0E:00/input/input2
Feb 15 11:14:09 achiles kernel: ACPI: Sleep Button (CM) [SLPB]
Feb 15 11:14:09 achiles kernel: ACPI: Transitioning device [FAN0] to D3
Feb 15 11:14:09 achiles kernel: fan PNP0C0B:00: registered as cooling_device0
Feb 15 11:14:09 achiles kernel: ACPI: Fan [FAN0] (off)
Feb 15 11:14:09 achiles kernel: ACPI: Transitioning device [FAN1] to D3
Feb 15 11:14:09 achiles kernel: fan PNP0C0B:01: registered as cooling_device1
Feb 15 11:14:09 achiles kernel: ACPI: Fan [FAN1] (off)
Feb 15 11:14:09 achiles kernel: ACPI: CPU0 (power states: C1[C1] C2[C2] C3[C3])
Feb 15 11:14:09 achiles kernel: processor ACPI0007:00: registered as cooling_device2
Feb 15 11:14:09 achiles kernel: ACPI: Processor [CPU0] (supports 8 throttling states)
Feb 15 11:14:09 achiles kernel: thermal LNXTHERM:01: registered as thermal_zone0
Feb 15 11:14:09 achiles kernel: ACPI: Thermal Zone [THRM] (33 C)
Feb 15 11:14:09 achiles kernel: isapnp: Scanning for PnP cards...
Feb 15 11:14:09 achiles kernel: isapnp: No Plug & Play device found
Feb 15 11:14:09 achiles kernel: Non-volatile memory driver v1.2
Feb 15 11:14:09 achiles kernel: Linux agpgart interface v0.103
Feb 15 11:14:09 achiles kernel: agpgart-intel 0000:00:00.0: Intel 855GM Chipset
Feb 15 11:14:09 achiles kernel: agpgart-intel 0000:00:00.0: detected 32636K stolen memory
Feb 15 11:14:09 achiles kernel: agpgart-intel 0000:00:00.0: AGP aperture is 128M @ 0xe8000000
Feb 15 11:14:09 achiles kernel: Serial: 8250/16550 driver4 ports, IRQ sharing enabled
Feb 15 11:14:09 achiles kernel: serial8250: ttyS1 at I/O 0x2f8 (irq = 3) is a NS16550A
Feb 15 11:14:09 achiles kernel: ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 10
Feb 15 11:14:09 achiles kernel: serial 0000:00:1f.6: PCI INT B -> Link[LNKB] -> GSI 10 (level, low) -> IRQ 10
Feb 15 11:14:09 achiles kernel: serial 0000:00:1f.6: PCI INT B disabled
Feb 15 11:14:09 achiles kernel: brd: module loaded
Feb 15 11:14:09 achiles kernel: loop: module loaded
Feb 15 11:14:09 achiles kernel: input: Macintosh mouse button emulation as /devices/virtual/input/input3
Feb 15 11:14:09 achiles kernel: Driver 'sd' needs updating - please use bus_type methods
Feb 15 11:14:09 achiles kernel: Driver 'sr' needs updating - please use bus_type methods
Feb 15 11:14:09 achiles kernel: ata_piix 0000:00:1f.1: power state changed by ACPI to D0
Feb 15 11:14:09 achiles kernel: ata_piix 0000:00:1f.1: enabling device (0005 -> 0007)
Feb 15 11:14:09 achiles kernel: ACPI: PCI Interrupt Link [LNKC] enabled at IRQ 6
Feb 15 11:14:09 achiles kernel: ata_piix 0000:00:1f.1: PCI INT A -> Link[LNKC] -> GSI 6 (level, low) -> IRQ 6
Feb 15 11:14:09 achiles kernel: scsi0 : ata_piix
Feb 15 11:14:09 achiles kernel: scsi1 : ata_piix
Feb 15 11:14:09 achiles kernel: ata1: PATA max UDMA/100 cmd 0x1f0 ctl 0x3f6 bmdma 0x1810 irq 14
Feb 15 11:14:09 achiles kernel: ata2: PATA max UDMA/100 cmd 0x170 ctl 0x376 bmdma 0x1818 irq 15
Feb 15 11:14:09 achiles kernel: ata1.00: ATA-6: HTS424040M9AT00, MA2OA71A, max UDMA/100
Feb 15 11:14:09 achiles kernel: ata1.00: 78140160 sectors, multi 16: LBA48 
Feb 15 11:14:09 achiles kernel: ata1.00: configured for UDMA/100
Feb 15 11:14:09 achiles kernel: ata2.00: ATAPI: QSI CD-RW/DVD-ROM SBW242C, UQ81, max UDMA/33
Feb 15 11:14:09 achiles kernel: ata2.00: configured for UDMA/33
Feb 15 11:14:09 achiles kernel: scsi 0:0:0:0: Direct-Access     ATA      HTS424040M9AT00  MA2O PQ: 0 ANSI: 5
Feb 15 11:14:09 achiles kernel: sd 0:0:0:0: [sda] 78140160 512-byte hardware sectors (40008 MB)
Feb 15 11:14:09 achiles kernel: sd 0:0:0:0: [sda] Write Protect is off
Feb 15 11:14:09 achiles kernel: sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
Feb 15 11:14:09 achiles kernel: sd 0:0:0:0: [sda] 78140160 512-byte hardware sectors (40008 MB)
Feb 15 11:14:09 achiles kernel: sd 0:0:0:0: [sda] Write Protect is off
Feb 15 11:14:09 achiles kernel: sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
Feb 15 11:14:09 achiles kernel: sda: sda1 sda2 sda3
Feb 15 11:14:09 achiles kernel: sd 0:0:0:0: [sda] Attached SCSI disk
Feb 15 11:14:09 achiles kernel: sd 0:0:0:0: Attached scsi generic sg0 type 0
Feb 15 11:14:09 achiles kernel: scsi 1:0:0:0: CD-ROM            QSI      CDRW/DVD SBW242C UQ81 PQ: 0 ANSI: 5
Feb 15 11:14:09 achiles kernel: sr0: scsi3-mmc drive: 1x/24x writer cd/rw xa/form2 cdda tray
Feb 15 11:14:09 achiles kernel: Uniform CD-ROM driver Revision: 3.20
Feb 15 11:14:09 achiles kernel: sr 1:0:0:0: Attached scsi generic sg1 type 5
Feb 15 11:14:09 achiles kernel: ACPI: PCI Interrupt Link [LNKH] enabled at IRQ 10
Feb 15 11:14:09 achiles kernel: ehci_hcd 0000:00:1d.7: PCI INT D -> Link[LNKH] -> GSI 10 (level, low) -> IRQ 10
Feb 15 11:14:09 achiles kernel: ehci_hcd 0000:00:1d.7: EHCI Host Controller
Feb 15 11:14:09 achiles kernel: ehci_hcd 0000:00:1d.7: new USB bus registered, assigned bus number 1
Feb 15 11:14:09 achiles kernel: ehci_hcd 0000:00:1d.7: debug port 1
Feb 15 11:14:09 achiles kernel: ehci_hcd 0000:00:1d.7: irq 10, io mem 0xe0100000
Feb 15 11:14:09 achiles kernel: ehci_hcd 0000:00:1d.7: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
Feb 15 11:14:09 achiles kernel: usb usb1: configuration #1 chosen from 1 choice
Feb 15 11:14:09 achiles kernel: hub 1-0:1.0: USB hub found
Feb 15 11:14:09 achiles kernel: hub 1-0:1.0: 6 ports detected
Feb 15 11:14:09 achiles kernel: usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
Feb 15 11:14:09 achiles kernel: usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
Feb 15 11:14:09 achiles kernel: usb usb1: Product: EHCI Host Controller
Feb 15 11:14:09 achiles kernel: usb usb1: Manufacturer: Linux 2.6.27.12-170.2.5.fc10.i686 ehci_hcd
Feb 15 11:14:09 achiles kernel: usb usb1: SerialNumber: 0000:00:1d.7
Feb 15 11:14:09 achiles kernel: USB Universal Host Controller Interface driver v3.0
Feb 15 11:14:09 achiles kernel: ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 6
Feb 15 11:14:09 achiles kernel: uhci_hcd 0000:00:1d.0: PCI INT A -> Link[LNKA] -> GSI 6 (level, low) -> IRQ 6
Feb 15 11:14:09 achiles kernel: uhci_hcd 0000:00:1d.0: UHCI Host Controller
Feb 15 11:14:09 achiles kernel: uhci_hcd 0000:00:1d.0: new USB bus registered, assigned bus number 2
Feb 15 11:14:09 achiles kernel: uhci_hcd 0000:00:1d.0: irq 6, io base 0x00001820
Feb 15 11:14:09 achiles kernel: usb usb2: configuration #1 chosen from 1 choice
Feb 15 11:14:09 achiles kernel: hub 2-0:1.0: USB hub found
Feb 15 11:14:09 achiles kernel: hub 2-0:1.0: 2 ports detected
Feb 15 11:14:09 achiles kernel: usb usb2: New USB device found, idVendor=1d6b, idProduct=0001
Feb 15 11:14:09 achiles kernel: usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
Feb 15 11:14:09 achiles kernel: usb usb2: Product: UHCI Host Controller
Feb 15 11:14:09 achiles kernel: usb usb2: Manufacturer: Linux 2.6.27.12-170.2.5.fc10.i686 uhci_hcd
Feb 15 11:14:09 achiles kernel: usb usb2: SerialNumber: 0000:00:1d.0
Feb 15 11:14:09 achiles kernel: ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 6
Feb 15 11:14:09 achiles kernel: uhci_hcd 0000:00:1d.1: PCI INT B -> Link[LNKD] -> GSI 6 (level, low) -> IRQ 6
Feb 15 11:14:09 achiles kernel: uhci_hcd 0000:00:1d.1: UHCI Host Controller
Feb 15 11:14:09 achiles kernel: uhci_hcd 0000:00:1d.1: new USB bus registered, assigned bus number 3
Feb 15 11:14:09 achiles kernel: uhci_hcd 0000:00:1d.1: irq 6, io base 0x00001840
Feb 15 11:14:09 achiles kernel: usb usb3: configuration #1 chosen from 1 choice
Feb 15 11:14:09 achiles kernel: hub 3-0:1.0: USB hub found
Feb 15 11:14:09 achiles kernel: hub 3-0:1.0: 2 ports detected
Feb 15 11:14:09 achiles kernel: usb 1-3: new high speed USB device using ehci_hcd and address 2
Feb 15 11:14:09 achiles kernel: usb usb3: New USB device found, idVendor=1d6b, idProduct=0001
Feb 15 11:14:09 achiles kernel: usb usb3: New USB device strings: Mfr=3, Product=2, SerialNumber=1
Feb 15 11:14:09 achiles kernel: usb usb3: Product: UHCI Host Controller
Feb 15 11:14:09 achiles kernel: usb usb3: Manufacturer: Linux 2.6.27.12-170.2.5.fc10.i686 uhci_hcd
Feb 15 11:14:09 achiles kernel: usb usb3: SerialNumber: 0000:00:1d.1
Feb 15 11:14:09 achiles kernel: uhci_hcd 0000:00:1d.2: PCI INT C -> Link[LNKC] -> GSI 6 (level, low) -> IRQ 6
Feb 15 11:14:09 achiles kernel: uhci_hcd 0000:00:1d.2: UHCI Host Controller
Feb 15 11:14:09 achiles kernel: uhci_hcd 0000:00:1d.2: new USB bus registered, assigned bus number 4
Feb 15 11:14:09 achiles kernel: uhci_hcd 0000:00:1d.2: irq 6, io base 0x00001860
Feb 15 11:14:09 achiles kernel: usb usb4: configuration #1 chosen from 1 choice
Feb 15 11:14:09 achiles kernel: hub 4-0:1.0: USB hub found
Feb 15 11:14:09 achiles kernel: hub 4-0:1.0: 2 ports detected
Feb 15 11:14:09 achiles kernel: usb 1-3: configuration #1 chosen from 1 choice
Feb 15 11:14:09 achiles kernel: usb 1-3: New USB device found, idVendor=046d, idProduct=09a4
Feb 15 11:14:09 achiles kernel: usb 1-3: New USB device strings: Mfr=0, Product=0, SerialNumber=2
Feb 15 11:14:09 achiles kernel: usb 1-3: SerialNumber: 46690111
Feb 15 11:14:09 achiles kernel: hub 2-0:1.0: over-current change on port 1
Feb 15 11:14:09 achiles kernel: usb usb4: New USB device found, idVendor=1d6b, idProduct=0001
Feb 15 11:14:09 achiles kernel: usb usb4: New USB device strings: Mfr=3, Product=2, SerialNumber=1
Feb 15 11:14:09 achiles kernel: usb usb4: Product: UHCI Host Controller
Feb 15 11:14:09 achiles kernel: usb usb4: Manufacturer: Linux 2.6.27.12-170.2.5.fc10.i686 uhci_hcd
Feb 15 11:14:09 achiles kernel: usb usb4: SerialNumber: 0000:00:1d.2
Feb 15 11:14:09 achiles kernel: PNP: PS/2 Controller [PNP0303:KBC,PNP0f13:MOU2] at 0x60,0x64 irq 1,12
Feb 15 11:14:09 achiles kernel: i8042.c: Detected active multiplexing controller, rev 1.1.
Feb 15 11:14:09 achiles kernel: serio: i8042 KBD port at 0x60,0x64 irq 1
Feb 15 11:14:09 achiles kernel: serio: i8042 AUX0 port at 0x60,0x64 irq 12
Feb 15 11:14:09 achiles kernel: serio: i8042 AUX1 port at 0x60,0x64 irq 12
Feb 15 11:14:09 achiles kernel: serio: i8042 AUX2 port at 0x60,0x64 irq 12
Feb 15 11:14:09 achiles kernel: serio: i8042 AUX3 port at 0x60,0x64 irq 12
Feb 15 11:14:09 achiles kernel: mice: PS/2 mouse device common for all mice
Feb 15 11:14:09 achiles kernel: rtc_cmos 00:01: rtc core: registered rtc_cmos as rtc0
Feb 15 11:14:09 achiles kernel: rtc0: alarms up to one month, y3k
Feb 15 11:14:09 achiles kernel: device-mapper: uevent: version 1.0.3
Feb 15 11:14:09 achiles kernel: device-mapper: ioctl: 4.14.0-ioctl (2008-04-23) initialised: dm-devel@redhat.com
Feb 15 11:14:09 achiles kernel: cpuidle: using governor ladder
Feb 15 11:14:09 achiles kernel: cpuidle: using governor menu
Feb 15 11:14:09 achiles kernel: Marking TSC unstable due to TSC halts in idle
Feb 15 11:14:09 achiles kernel: input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input4
Feb 15 11:14:09 achiles kernel: hub 2-0:1.0: over-current change on port 2
Feb 15 11:14:09 achiles kernel: usb 3-2: new low speed USB device using uhci_hcd and address 2
Feb 15 11:14:09 achiles kernel: usb 3-2: configuration #1 chosen from 1 choice
Feb 15 11:14:09 achiles kernel: usb 3-2: New USB device found, idVendor=05e3, idProduct=1205
Feb 15 11:14:09 achiles kernel: usb 3-2: New USB device strings: Mfr=0, Product=1, SerialNumber=0
Feb 15 11:14:09 achiles kernel: usb 3-2: Product: USB Mouse              
Feb 15 11:14:09 achiles kernel: hub 1-0:1.0: over-current change on port 1
Feb 15 11:14:09 achiles kernel: hub 1-0:1.0: over-current change on port 2
Feb 15 11:14:09 achiles kernel: usbcore: registered new interface driver hiddev
Feb 15 11:14:09 achiles kernel: input: USB Mouse               as /devices/pci0000:00/0000:00:1d.1/usb3/3-2/3-2:1.0/input/input5
Feb 15 11:14:09 achiles kernel: input,hidraw0: USB HID v1.10 Mouse [USB Mouse              ] on usb-0000:00:1d.1-2
Feb 15 11:14:09 achiles kernel: usbcore: registered new interface driver usbhid
Feb 15 11:14:09 achiles kernel: usbhid: v2.6:USB HID core driver
Feb 15 11:14:09 achiles kernel: nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
Feb 15 11:14:09 achiles kernel: CONFIG_NF_CT_ACCT is deprecated and will be removed soon. Plase use
Feb 15 11:14:09 achiles kernel: nf_conntrack.acct=1 kernel paramater, acct=1 nf_conntrack module option or
Feb 15 11:14:09 achiles kernel: sysctl net.netfilter.nf_conntrack_acct=1 to enable it.
Feb 15 11:14:09 achiles kernel: ip_tables: (C) 2000-2006 Netfilter Core Team
Feb 15 11:14:09 achiles kernel: TCP cubic registered
Feb 15 11:14:09 achiles kernel: Initializing XFRM netlink socket
Feb 15 11:14:09 achiles kernel: NET: Registered protocol family 17
Feb 15 11:14:09 achiles kernel: Using IPI No-Shortcut mode
Feb 15 11:14:09 achiles kernel: registered taskstats version 1
Feb 15 11:14:09 achiles kernel:  Magic number: 13:434:226
Feb 15 11:14:09 achiles kernel: Freeing unused kernel memory: 412k freed
Feb 15 11:14:09 achiles kernel: Write protecting the kernel text: 2744k
Feb 15 11:14:09 achiles kernel: Write protecting the kernel read-only data: 1172k
Feb 15 11:14:09 achiles kernel: Synaptics Touchpad, model: 1, fw: 5.9, id: 0x126eb1, caps: 0xa04713/0x4000
Feb 15 11:14:09 achiles kernel: input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio4/input/input6
Feb 15 11:14:09 achiles kernel: kjournald starting.  Commit interval 5 seconds
Feb 15 11:14:09 achiles kernel: EXT3-fs: mounted filesystem with ordered data mode.
Feb 15 11:14:09 achiles kernel: type=1404 audit(1234696430.918:2): enforcing=1 old_enforcing=0 auid=4294967295 ses=4294967295
Feb 15 11:14:09 achiles kernel: type=1403 audit(1234696431.566:3): policy loaded auid=4294967295 ses=4294967295
Feb 15 11:14:09 achiles kernel: udevd version 127 started
Feb 15 11:14:09 achiles kernel: ACPI: SBS HC: EC = 0xf7810d20, offset = 0x18, query_bit = 0x20
Feb 15 11:14:09 achiles kernel: NET: Registered protocol family 23
Feb 15 11:14:09 achiles kernel: nsc-ircc, chip->init
Feb 15 11:14:09 achiles kernel: nsc-ircc, Found chip at base=0x164e
Feb 15 11:14:09 achiles kernel: nsc-ircc, driver loaded (Dag Brattli)
Feb 15 11:14:09 achiles kernel: nsc_ircc_open(), can't get iobase of 0x2f8
Feb 15 11:14:09 achiles kernel: nsc-ircc, Found chip at base=0x164e
Feb 15 11:14:09 achiles kernel: nsc-ircc, driver loaded (Dag Brattli)
Feb 15 11:14:09 achiles kernel: nsc_ircc_open(), can't get iobase of 0x2f8
Feb 15 11:14:09 achiles kernel: nsc-ircc 00:08: disabled
Feb 15 11:14:09 achiles kernel: input: PC Speaker as /devices/platform/pcspkr/input/input7
Feb 15 11:14:09 achiles kernel: acpi device:06: registered as cooling_device3
Feb 15 11:14:09 achiles kernel: input: Video Bus as /devices/LNXSYSTM:00/device:00/PNP0A03:00/device:02/input/input8
Feb 15 11:14:09 achiles kernel: ACPI: Video Device [GFX0] (multi-head: yes  rom: yes  post: no)
Feb 15 11:14:09 achiles kernel: ACPI: WMI: Mapper loaded
Feb 15 11:14:09 achiles kernel: acer-wmi: Acer Laptop ACPI-WMI Extras
Feb 15 11:14:09 achiles kernel: acer-wmi: No or unsupported WMI interface, unable to load
Feb 15 11:14:09 achiles kernel: ACPI: Smart Battery System [SBS0]: AC Adapter [AC0] (on-line)
Feb 15 11:14:09 achiles kernel: ACPI: Smart Battery System [SBS0]: Battery Slot [BAT0] (battery present)
Feb 15 11:14:09 achiles kernel: ACPI: Smart Battery System [SBS0]: Battery Slot [BAT1] (battery absent)
Feb 15 11:14:09 achiles kernel: Linux video capture interface: v2.00
Feb 15 11:14:09 achiles kernel: uvcvideo: Found UVC 1.00 device <unnamed> (046d:09a4)
Feb 15 11:14:09 achiles kernel: uvcvideo: UVC non compliance - GET_DEF(PROBE) not supported. Enabling workaround.
Feb 15 11:14:09 achiles kernel: input: UVC Camera (046d:09a4) as /devices/pci0000:00/0000:00:1d.7/usb1/1-3/1-3:1.0/input/input9
Feb 15 11:14:09 achiles kernel: usbcore: registered new interface driver uvcvideo
Feb 15 11:14:09 achiles kernel: USB Video Class driver (v0.1.0)
Feb 15 11:14:09 achiles kernel: intel_rng: FWH not detected
Feb 15 11:14:09 achiles kernel: b44 0000:02:02.0: PCI INT A -> Link[LNKD] -> GSI 6 (level, low) -> IRQ 6
Feb 15 11:14:09 achiles kernel: ssb: Sonics Silicon Backplane found on PCI device 0000:02:02.0
Feb 15 11:14:09 achiles kernel: b44.c:v2.0
Feb 15 11:14:09 achiles kernel: eth0: Broadcom 44xx/47xx 10/100BaseT Ethernet 00:c0:9f:59:b1:19
Feb 15 11:14:09 achiles kernel: ieee80211: 802.11 data/management/control stack, git-1.1.13
Feb 15 11:14:09 achiles kernel: ieee80211: Copyright (C) 2004-2005 Intel Corporation <jketreno@linux.intel.com>
Feb 15 11:14:09 achiles kernel: ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.2kmprq
Feb 15 11:14:09 achiles kernel: ipw2200: Copyright(c) 2003-2006 Intel Corporation
Feb 15 11:14:09 achiles kernel: ipw2200 0000:02:04.0: PCI INT A -> Link[LNKB] -> GSI 10 (level, low) -> IRQ 10
Feb 15 11:14:09 achiles kernel: ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
Feb 15 11:14:09 achiles kernel: firmware: requesting ipw2200-bss.fw
Feb 15 11:14:09 achiles kernel: iTCO_vendor_support: vendor-support=0
Feb 15 11:14:09 achiles kernel: iTCO_wdt: Intel TCO WatchDog Timer Driver v1.03 (30-Apr-2008)
Feb 15 11:14:09 achiles kernel: iTCO_wdt: Found a ICH4-M TCO device (Version=1, TCOBASE=0x1060)
Feb 15 11:14:09 achiles kernel: iTCO_wdt: initialized. heartbeat=30 sec (nowayout=0)
Feb 15 11:14:09 achiles kernel: ipw2200: Detected geography ZZM (11 802.11bg channels, 0 802.11a channels)
Feb 15 11:14:09 achiles kernel: i801_smbus 0000:00:1f.3: PCI INT B -> Link[LNKB] -> GSI 10 (level, low) -> IRQ 10
Feb 15 11:14:09 achiles kernel: tifm_7xx1 0000:02:06.3: PCI INT A -> Link[LNKE] -> GSI 10 (level, low) -> IRQ 10
Feb 15 11:14:09 achiles kernel: Yenta: CardBus bridge found at 0000:02:06.0 [1025:0064]
Feb 15 11:14:09 achiles kernel: Yenta: Enabling burst memory read transactions
Feb 15 11:14:09 achiles kernel: Yenta: Using CSCINT to route CSC interrupts to PCI
Feb 15 11:14:09 achiles kernel: Yenta: Routing CardBus interrupts to PCI
Feb 15 11:14:09 achiles kernel: Yenta TI: socket 0000:02:06.0, mfunc 0x01a21b22, devctl 0x64
Feb 15 11:14:09 achiles kernel: Yenta: ISA IRQ mask 0x08b8, PCI irq 10
Feb 15 11:14:09 achiles kernel: Socket status: 30000006
Feb 15 11:14:09 achiles kernel: Yenta: Raising subordinate bus# of parent bus (#02) from #02 to #06
Feb 15 11:14:09 achiles kernel: pcmcia: parent PCI bridge I/O window: 0x3000 - 0x3fff
Feb 15 11:14:09 achiles kernel: cs: IO port probe 0x3000-0x3fff: clean.
Feb 15 11:14:09 achiles kernel: pcmcia: parent PCI bridge Memory window: 0xe0200000 - 0xe05fffff
Feb 15 11:14:09 achiles kernel: pcmcia: parent PCI bridge Memory window: 0x60000000 - 0x65ffffff
Feb 15 11:14:09 achiles kernel: firewire_ohci 0000:02:06.2: PCI INT A -> Link[LNKE] -> GSI 10 (level, low) -> IRQ 10
Feb 15 11:14:09 achiles kernel: firewire_ohci: Added fw-ohci device 0000:02:06.2, OHCI version 1.10
Feb 15 11:14:09 achiles kernel: cs: IO port probe 0x100-0x3af: clean.
Feb 15 11:14:09 achiles kernel: cs: IO port probe 0x3e0-0x4ff: clean.
Feb 15 11:14:09 achiles kernel: cs: IO port probe 0x820-0x8ff: clean.
Feb 15 11:14:09 achiles kernel: cs: IO port probe 0xc00-0xcf7: clean.
Feb 15 11:14:09 achiles kernel: cs: IO port probe 0xa00-0xaff: clean.
Feb 15 11:14:09 achiles kernel: firewire_core: created device fw0: GUID 00c09f00002a709e, S400
Feb 15 11:14:09 achiles kernel: Intel ICH 0000:00:1f.5: PCI INT B -> Link[LNKB] -> GSI 10 (level, low) -> IRQ 10
Feb 15 11:14:09 achiles kernel: intel8x0_measure_ac97_clock: measured 50940 usecs
Feb 15 11:14:09 achiles kernel: intel8x0: clocking to 48000
Feb 15 11:14:09 achiles kernel: Intel ICH Modem 0000:00:1f.6: PCI INT B -> Link[LNKB] -> GSI 10 (level, low) -> IRQ 10
Feb 15 11:14:09 achiles kernel: ALSA sound/pci/ac97/ac97_codec.c:2154: MC'97 0 converters and GPIO not ready (0x1)
Feb 15 11:14:09 achiles kernel: ALSA sound/usb/usbaudio.c:1298: 2:3:1: cannot get freq at ep 0x86
Feb 15 11:14:09 achiles kernel: usbcore: registered new interface driver snd-usb-audio
Feb 15 11:14:09 achiles kernel: device-mapper: multipath: version 1.0.5 loaded
Feb 15 11:14:09 achiles kernel: EXT3 FS on dm-0, internal journal
Feb 15 11:14:09 achiles kernel: kjournald starting.  Commit interval 5 seconds
Feb 15 11:14:09 achiles kernel: EXT3 FS on sda2, internal journal
Feb 15 11:14:09 achiles kernel: EXT3-fs: mounted filesystem with ordered data mode.
Feb 15 11:14:09 achiles kernel: Adding 1015800k swap on /dev/mapper/VolGroup00-LogVol01.  Priority:-1 extents:1 across:1015800k
Feb 15 11:14:09 achiles kernel: IA-32 Microcode Update Driver: v1.14a <tigran@aivazian.fsnet.co.uk>
Feb 15 11:14:09 achiles kernel: firmware: requesting intel-ucode/06-0d-06
Feb 15 11:14:09 achiles kernel: microcode: CPU0 updated from revision 0x17 to 0x18, date = 10172004 
Feb 15 11:14:09 achiles kernel: Clocksource tsc unstable (delta = -99697894 ns)
Feb 15 11:14:09 achiles kernel: NET: Registered protocol family 10
Feb 15 11:14:09 achiles kernel: lo: Disabled Privacy Extensions
Feb 15 11:14:09 achiles kernel: ip6_tables: (C) 2000-2006 Netfilter Core Team
Feb 15 11:14:09 achiles rsyslogd: [origin software="rsyslogd" swVersion="3.21.9" x-pid="1763" x-info="http://www.rsyslog.com"] restart
Feb 15 11:14:10 achiles rpc.statd[1794]: Version 1.1.4 Starting
Feb 15 11:14:10 achiles kernel: RPC: Registered udp transport module.
Feb 15 11:14:10 achiles kernel: RPC: Registered tcp transport module.
Feb 15 11:14:12 achiles acpid: starting up
Feb 15 11:14:14 achiles kernel: ttyS1: LSR safety check engaged!
Feb 15 11:14:16 achiles acpid: client connected from 2051[68:68]
Feb 15 11:14:16 achiles pcscd: pcscdaemon.c:498:main() pcsc-lite 1.4.102 daemon ready.
Feb 15 11:14:17 achiles NetworkManager: <info>  starting...
Feb 15 11:14:17 achiles NetworkManager: <WARN>  nm_generic_enable_loopback(): error -17 returned from rtnl_addr_add():#012Sucess#012
Feb 15 11:14:17 achiles NetworkManager: <info>  Found radio killswitch /org/freedesktop/Hal/devices/ipw_wlan_switch
Feb 15 11:14:17 achiles NetworkManager: <info>  eth0: driver is 'b44'.
Feb 15 11:14:17 achiles NetworkManager: <info>  Found new Ethernet device 'eth0'.
Feb 15 11:14:17 achiles NetworkManager: <info>  (eth0): exported as /org/freedesktop/Hal/devices/net_00_c0_9f_59_b1_19
Feb 15 11:14:17 achiles NetworkManager: <info>  eth1: driver is 'ipw2200'.
Feb 15 11:14:17 achiles NetworkManager: <info>  eth1: driver supports SSID scans (scan_capa 0x21).
Feb 15 11:14:17 achiles NetworkManager: <info>  Found new 802.11 WiFi device 'eth1'.
Feb 15 11:14:17 achiles NetworkManager: <info>  (eth1): exported as /org/freedesktop/Hal/devices/net_00_0e_35_80_85_b6
Feb 15 11:14:17 achiles NetworkManager: <info>  Trying to start the supplicant...
Feb 15 11:14:17 achiles NetworkManager: <info>  Trying to start the system settings daemon...
Feb 15 11:14:18 achiles nm-system-settings: Loaded plugin ifcfg-rh: (c) 2007 - 2008 Red Hat, Inc.  To report bugs please use the NetworkManager mailing list.
Feb 15 11:14:18 achiles NetworkManager: <info>  (eth1): supplicant manager state:  down -> idle
Feb 15 11:14:19 achiles nm-system-settings:    ifcfg-rh: parsing /etc/sysconfig/network-scripts/ifcfg-lo ... 
Feb 15 11:14:19 achiles nm-system-settings:    ifcfg-rh:     error: Ignoring loopback device config.
Feb 15 11:14:19 achiles nm-system-settings:    ifcfg-rh: parsing /etc/sysconfig/network-scripts/ifcfg-eth1 ... 
Feb 15 11:14:19 achiles nm-system-settings:    ifcfg-rh:     error: Missing SSID
Feb 15 11:14:19 achiles nm-system-settings:    ifcfg-rh: parsing /etc/sysconfig/network-scripts/ifcfg-eth0 ... 
Feb 15 11:14:20 achiles nm-system-settings:    ifcfg-rh:     read connection 'System eth0'
Feb 15 11:14:20 achiles nm-system-settings:    ifcfg-rh: Ignoring connection 'System eth0' and its device because NM_CONTROLLED was false.
Feb 15 11:14:20 achiles NetworkManager: <info>  (eth0): now unmanaged
Feb 15 11:14:21 achiles ntpd[2114]: ntpd 4.2.4p6@1.1549-o Mon Jan 12 14:07:28 UTC 2009 (1)
Feb 15 11:14:21 achiles ntpd[2115]: precision = 1.397 usec
Feb 15 11:14:21 achiles ntpd[2115]: Listening on interface #0 wildcard, 0.0.0.0#123 Disabled
Feb 15 11:14:21 achiles ntpd[2115]: Listening on interface #1 wildcard, ::#123 Disabled
Feb 15 11:14:21 achiles ntpd[2115]: Listening on interface #2 lo, ::1#123 Enabled
Feb 15 11:14:21 achiles ntpd[2115]: Listening on interface #3 lo, 127.0.0.1#123 Enabled
Feb 15 11:14:21 achiles ntpd[2115]: Listening on routing socket on fd #20 for interface updates
Feb 15 11:14:21 achiles ntpd[2115]: kernel time sync status 0040
Feb 15 11:14:21 achiles ntpd[2115]: frequency initialized 5.750 PPM from /var/lib/ntp/drift
Feb 15 11:14:21 achiles NetworkManager: <info>  (eth1): device state change: 1 -> 2
Feb 15 11:14:21 achiles NetworkManager: <info>  (eth1): bringing up device.
Feb 15 11:14:21 achiles NetworkManager: <info>  (eth1): preparing device.
Feb 15 11:14:21 achiles NetworkManager: <info>  (eth1): deactivating device (reason: 2).
Comment 3 Gerard Fernandes 2009-02-17 04:54:21 EST
Created attachment 332202 [details]
log for the 16th Feb

Log for the 16th Feb
Comment 4 Gerard Fernandes 2009-02-17 04:55:55 EST
Ignore the log posted in the comment above - of course the Log Viewer doesn't really copy correct text when filtered!!!! Doh! (BTW - isn't this a bug?) So I've attached unfiltered logs for the 16th instead.
Comment 5 Dan Williams 2009-02-17 06:38:43 EST
Any idea which updates got installed on the 16th?  The system logs should tell you somewhere; I think both PackageKit and yum log that somewhere.  What kernel version are you running?

The WPA password you're seeing is the WPA hex key, which is what your WPA passphrase gets converted into anyway; there's an open bug to show the real passphrase and not the WPA Hex key but that's a bit of work to do.

In any case, have you tried rebooting the router when this happens?  I have a WRT54G (and an ipw2200 card) and I do have to periodically reboot the router because it just locks up and won't accept connections.  The Vista laptop using an Intel 4965 card also gets kicked off at the same time, indicating router issues.

So next time this happens, try unplugging the router for 30 seconds, plugging it back in, choosing disabling wireless from the applet's right-click menu, re-enabling wireless, then connecting.  Lets see if it could be a router issue.
Comment 6 Gerard Fernandes 2009-02-17 07:41:05 EST
I'll send you the exact kernel version and the updates installed on the 16th - but the kernel is the latest stable kernel available via the Fedora 10 repositories.

I've tried rebooting the router and the modem both. There is no difference in behavior after rebooting. My laptop dual-boots to WinXP and I can connect to the wireless LAN through WinXP. So that rules out router issues. My laptop is the only machine connected to the router.

I've tried disabling wireless (both via NetworkManager and via the radio-kill switch), then enabling and retrying. Doesn't work.

I've also tried deleting all wireless networks, deleting all keys in SeaHorse, restarting NetworkManager and then attempting to connect afresh. This fails as well.

What really takes the cake though is NetworkManager refusing to recognise a wired network when connected to the router with an ethernet cable! The only way I can get the network to work is to stop NetworkManager and then manually bring up the "eth0" (wired) interface via System/Administration/Network.
Comment 7 Gerard Fernandes 2009-02-18 03:21:26 EST
Yum log for the 16th - 1 package (pidgin-otr) installed and 2 updated:

Feb 16 19:45:56 Installed: libotr-3.2.0-2.fc10.i386
Feb 16 19:45:57 Installed: pidgin-otr-3.2.0-1.fc10.i386
Feb 16 19:48:44 Updated: xsane-gimp-0.996-3.fc10.i386
Feb 16 19:48:51 Updated: xsane-0.996-3.fc10.i386

Linux kernel version: 2.6.27.12-170.2.5.fc10.i686
Comment 8 Gerard Fernandes 2009-02-19 06:01:13 EST
Ok - the problem seems to have now gone away. I can connect by wireless now.

I can't see anything obvious in the logs for when it was failing - just timeouts. I can't see anything obvious in the packages installed/updated on the 16th either.

So it's completely baffling that Windows could connect from the same laptop (from the same location too) while Fedora failed to connect with timeouts.

I can see random wild fluctuations in network strength though (from 0%-90%) - which I don't see in Windows XP SP3 (always shows 85%+). I'm using wireless G only and WPA2. This happens even when I'm just a couple of feet away from the router.

The only open question now is - why is the wired connection not controlled by NetworkManager? I had to manually change this in '/etc/sysconfig/network-scripts/ifcfg-eth0' and remove the NM_CONTROLLED flag.

However, this seems to have been reported in other bugs against NM, so I'd probably say there's no point keeping this bug open anymore.
Comment 9 Gerard Fernandes 2009-02-19 06:22:08 EST
The wireless problems I'm seeing seem related to this bug filed with Ubuntu (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/264104). I see the same errors when connections are dropped - search for the following strings (without the quotes) in the attached log:
1."Failed to send SYSTEM_CONFIG: Already sending"
2."ipw2200: Firmware error detected.  Restarting"

Could it be the same thing affecting Fedora as well? Seems to be a bug in the ipw2200 driver causing it to trip over NetworkManager in scanning for wireless links.
Comment 10 Dan Williams 2009-02-19 12:21:27 EST
(In reply to comment #9)
> The wireless problems I'm seeing seem related to this bug filed with Ubuntu
> (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/264104). I see the same
> errors when connections are dropped - search for the following strings (without
> the quotes) in the attached log:
> 1."Failed to send SYSTEM_CONFIG: Already sending"
> 2."ipw2200: Firmware error detected.  Restarting"
> 
> Could it be the same thing affecting Fedora as well? Seems to be a bug in the
> ipw2200 driver causing it to trip over NetworkManager in scanning for wireless
> links.

Yes, there's a patch scheduled for 2.6.29 that will fix that scanning firmware crash.  That could certainly have an impact on NetworkManager's performance.
Comment 11 Dan Williams 2009-02-19 12:22:16 EST
Since you report the problem is gone, I'll mark closed.   Please reopen if you see it again.  Thanks!
Comment 12 Gerard Fernandes 2009-02-19 14:29:24 EST
Thanks - I will keep a lookout for the patch.

I think this is really an edge-case scenario - something to do with a crowded radio-frequency range (Channel-11 seems to be the default on most wireless routers) and perhaps some electro-magnetic interference that was causing signal degradation. In turn, this must have cause NetworkManager and the ipw2200 driver to begin a scan for perhaps a better connection, and then they'd both trip over each other.

I've changed to another channel, moved the router away from a potentially high electro-magnetic field and I now get very strong signal strength. This in turn probably means both NM and the ipw driver don't have to keep scanning - just guessing here, since I've not seen any code :)

Note You need to log in before you can comment on or make changes to this bug.