Bug 485919 - Building a CD/DVD installer image for rawhide gives traceback
Building a CD/DVD installer image for rawhide gives traceback
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: revisor (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-17 08:54 EST by Jasper Capel
Modified: 2009-05-31 08:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-31 08:17:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jasper Capel 2009-02-17 08:54:27 EST
Description of problem:
Building a CD/DVD installer image for rawhide gives traceback

Version-Release number of selected component (if applicable):
revisor-2.1.3-2.fc11.noarch

Steps to Reproduce:
1. Start Revisor
2. Enter root password
3. Pick CD or DVD set
4. Pick rawhide-x86_64 as configuration section
5. Skip the kickstart screen
6. Choose packages, package selection doesn't seem to matter, I tried a minimal selection as well as a full desktop one.

  
Actual results:
SELinux on this host is disabled. Composed media will not have SELinux, and as a result the system you install from the composed media will not have SELinux either.
Reading configuration file /etc/revisor/revisor.conf
Loaded plugins: dellsysidplugin2, refresh-packagekit
/usr/lib/python2.6/site-packages/yum/__init__.py:177: UserWarning: Use .preconf instead of passing args to _getConfig
  warnings.warn('Use .preconf instead of passing args to _getConfig')
Package ibus-chewing is obsoleted by ibus, trying to install ibus-1.1.0.20090211-9.fc11.x86_64 instead
Using mirrorlist http://mirrors.fedoraproject.org/mirrorlist?repo=rawhide&arch=x86_64 from repo development
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/revisor/modgui/ready_screen.py", line 145, in button_forward_clicked
    self.gui.next()
  File "/usr/lib/python2.6/site-packages/revisor/modgui/__init__.py", line 448, in next
    self.default[self.current]['disp'](self)
  File "/usr/lib/python2.6/site-packages/revisor/modgui/__init__.py", line 315, in displayBuildMedia
    self.BuildMedia.start()
  File "/usr/lib/python2.6/site-packages/revisor/modgui/build_media.py", line 65, in start
    self.base.lift_off()
  File "/usr/lib/python2.6/site-packages/revisor/base.py", line 1172, in lift_off
    self.buildInstallationMedia()
  File "/usr/lib/python2.6/site-packages/revisor/base.py", line 1491, in buildInstallationMedia
    mypungi.doGetRelnotes(callback=pungicallback)
  File "/usr/lib/python2.6/site-packages/revisor/pungi.py", line 379, in doGetRelnotes
    shutil.copy(os.path.join(dirpath, filename), os.path.join(self.topdir, filename))
  File "/usr/lib64/python2.6/shutil.py", line 88, in copy
    copyfile(src, dst)
  File "/usr/lib64/python2.6/shutil.py", line 52, in copyfile
    fsrc = open(src, 'rb')
IOError: [Errno 2] No such file or directory: '/var/tmp/revisor-pungi/work/rawhide-x86_64/x86_64/docs/etc/pki/rpm-gpg/RPM-GPG-KEY-fedora'

and a defunct rpm2cpio process under the revisor process in ps aux. The GUI hangs on "Linking in Release Notes".


Expected results:
A nice CD/DVD image for rawhide :-)

Additional info:
Contact me if you need any more info. I'm also on freenode (as jcapel).
Comment 1 Jeroen van Meeuwen 2009-02-17 09:06:25 EST
This has been fixed in git and has to do with "dead" symbolic links in the fedora-release package, where there's no real GPG key yet, since it hasn't been generated for Fedora 11, yet.
Comment 2 Jeroen van Meeuwen 2009-05-31 08:17:28 EDT
Fixed in rawhide (2.1.5)

Note You need to log in before you can comment on or make changes to this bug.