Bug 485924 - GFS2: file system larger than logical volume according to df
GFS2: file system larger than logical volume according to df
Status: CLOSED DUPLICATE of bug 494885
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Steve Whitehouse
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-17 09:26 EST by Nate Straz
Modified: 2009-06-23 11:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-23 11:14:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log from growfs test (8.80 KB, text/plain)
2009-02-17 09:26 EST, Nate Straz
no flags Details
savemeta output (1.12 MB, application/octet-stream)
2009-02-17 09:31 EST, Nate Straz
no flags Details

  None (edit)
Description Nate Straz 2009-02-17 09:26:49 EST
Created attachment 332219 [details]
Log from growfs test

Description of problem:

After growing the file system several times, df states that the file system is larger than the volume on which it resides.

  LV       VG         Attr   LSize   Origin Snap%  Move Log Copy%  Convert
  grow1    growfs     -wi-ao 190.70G

Filesystem            Size  Used Avail Use% Mounted on
/dev/mapper/growfs-grow1
                      245G  391M  245G   1% /mnt/grow1

The last gfs2_grow showed that the file system grew:

growing grow1 on z3
FS: Mount Point: /mnt/grow1
FS: Device:      /dev/mapper/growfs-grow1
FS: Size:        46418548 (0x2c44a74)
FS: RG size:     64921 (0xfd99)
DEV: Size:       49989632 (0x2fac800)
The file system grew by 13949MB.
gfs2_grow complete.

But the kernel messages show that it didn't.

Feb 16 17:30:55 z3 qarshd[28375]: Running cmdline: gfs2_grow /mnt/grow1
Feb 16 17:30:56 z3 kernel: GFS2: fsid=Z_Cluster:grow1.2: File system extended by 0 blocks.


Version-Release number of selected component (if applicable):
kernel-2.6.18-128.1.1.el5
gfs2-utils-0.1.53-1.el5_3.1


How reproducible:
It took 13 grows last time to hit it

Steps to Reproduce:
1. Run growfs test
  
Actual results:


Expected results:


Additional info:
Comment 1 Nate Straz 2009-02-17 09:31:42 EST
Created attachment 332220 [details]
savemeta output
Comment 2 Nate Straz 2009-05-21 08:00:15 EDT
I'm still hitting this in pre-beta testing.  It would be good to fit into the release if possible.
Comment 3 RHEL Product and Program Management 2009-05-21 08:18:02 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 5 Ben Marzinski 2009-06-23 11:14:47 EDT

*** This bug has been marked as a duplicate of bug 494885 ***

Note You need to log in before you can comment on or make changes to this bug.