Bug 485980 - selinux denial
selinux denial
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: taskcoach (Show other bugs)
10
All Linux
high Severity high
: ---
: ---
Assigned To: Rakesh Pandit
Fedora Extras Quality Assurance
:
: 495533 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-17 14:05 EST by Lev Shamardin
Modified: 2009-10-13 21:40 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.71.5-2.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-22 06:16:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lev Shamardin 2009-02-17 14:05:19 EST
Description of problem:
Running taskcoach with enabled SELinux in default configuration produces errors, and perhaps limits taskcoach functionality.

Version-Release number of selected component (if applicable):
taskcoach-0.71.5-1.fc10.noarch

How reproducible:
Always.

Steps to Reproduce:
1. Enable SELinux in enforcing mode.
2. Install taskcoach.
2. Run taskcoach.
  
Actual results:
node=abbot.homeunix.net type=AVC msg=audit(1234897037.697:175): avc: denied { execmod } for pid=10687 comm="taskcoach" path="/usr/lib/python2.5/site-packages/taskcoachlib/bin.in/linux/_pysyncml.so" dev=sda2 ino=2812289 scontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tcontext=system_u:object_r:lib_t:s0 tclass=file 

node=abbot.homeunix.net type=SYSCALL msg=audit(1234897037.697:175): arch=40000003 syscall=125 success=no exit=-13 a0=8bcb000 a1=8b000 a2=5 a3=bf9ae0f0 items=0 ppid=10114 pid=10687 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=pts8 ses=1 comm="taskcoach" exe="/usr/bin/python" subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 key=(null) 

Expected results:
No errors.

Additional info:
As setroubleshoot suggests, check http://people.redhat.com/drepper/selinux-mem.html
Comment 1 Rakesh Pandit 2009-03-07 04:26:49 EST
Looking into it. Thanks for reporting.
Comment 2 Rakesh Pandit 2009-05-04 02:23:18 EDT
It seems to be 32 bit specific .. may you confirm ?
Comment 3 Rakesh Pandit 2009-09-22 01:29:20 EDT
http://kojipkgs.fedoraproject.org/packages/taskcoach/0.71.5/2.fc10/noarch/taskcoach-0.71.5-2.fc10.noarch.rpm

May you check with this whether it is still reproducable ?

Thanks,
Comment 4 Lev Shamardin 2009-09-22 06:00:01 EDT
Yes, the new rpm seems to solve the problem.
Comment 5 Rakesh Pandit 2009-09-22 06:16:29 EDT
Thanks .. I have requested update to be pushed to bodhi-testing .. in case problem occurs again .. feel free to reopen.

Thanks,

https://admin.fedoraproject.org/updates/taskcoach-0.71.5-2.fc10
Comment 6 Rakesh Pandit 2009-09-23 07:06:07 EDT
*** Bug 495533 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2009-10-13 21:39:53 EDT
taskcoach-0.71.5-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.