Bug 485990 - substring searches match null values
substring searches match null values
Status: CLOSED DUPLICATE of bug 174394
Product: Red Hat Directory Server
Classification: Red Hat
Component: Database - Indexes/Searches (Show other bugs)
8.0
All All
low Severity medium
: ---
: ---
Assigned To: Noriko Hosoi
Chandrasekar Kannan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-17 14:57 EST by Ulf Weltman
Modified: 2015-01-04 18:36 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-18 15:17:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ulf Weltman 2009-02-17 14:57:04 EST
If you have add two test entries like this (note the empty title value in the second entry):
dn: uid=test1,dc=cup,dc=hp,dc=com
objectClass: top
objectClass: organizationalperson
objectClass: inetorgperson
objectClass: person
uid: test1
sn: test1
cn: test1
title: test1

dn: uid=test2,dc=cup,dc=hp,dc=com
objectClass: top
objectClass: organizationalperson
objectClass: inetorgperson
objectClass: person
uid: test2
sn: test2
cn: test2
title:

Then a search like this will return BOTH of them:
ldapsearch -b "dc=cup,dc=hp,dc=com" "title=*est*"
Comment 1 Ulf Weltman 2009-02-17 21:30:57 EST
Actually this seems to be fixed in a build from the tip pulled about a week ago.  I haven't found the change that fixed it though.  Anyone recall fixing it? :)
Comment 2 Noriko Hosoi 2009-02-18 14:54:35 EST
It works fine for me, too. :)  And I don't recall any fixes related to the bug...

How old was the server when you observed the bug?  Weeks?  Months?
Comment 3 Ulf Weltman 2009-02-18 15:05:46 EST
I can reproduce the bug with 8.0 builds and it was originally reported in 6.11.
Comment 4 Noriko Hosoi 2009-02-18 15:15:39 EST
Found it! Nathan fixed it recently.

Bug 174394 -  Substring regex gets confused by empty values 
https://bugzilla.redhat.com/show_bug.cgi?id=174394
Comment 5 Noriko Hosoi 2009-02-18 15:17:26 EST

*** This bug has been marked as a duplicate of bug 174394 ***

Note You need to log in before you can comment on or make changes to this bug.