Bug 486003 - Installer Echoes Password to The World
Installer Echoes Password to The World
Status: CLOSED DUPLICATE of bug 484303
Product: Fedora
Classification: Fedora
Component: system-config-users (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-17 15:49 EST by Daniel Qarras
Modified: 2009-02-18 05:38 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-18 05:38:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Qarras 2009-02-17 15:49:22 EST
Description of problem:
After installing Fedora 11 Alpha and creating a user during firstboot a valid password was rejected and echoed to the world in part of the error window!

What I mean by valid password is a 8 char long password with upper and lower case letters, a digit and a special character.

Version-Release number of selected component (if applicable):
Fedora 11 Alpha.

How reproducible:
Always.

Steps to Reproduce:
1. Install F11a.
2. Create a user with a valid password.
3. Stun as your valuable password is echoed to the world.
  
Actual results:
Password rejected and echoed.

Expected results:
Password accepted. Even if not accepted it should *never* be echoed to the world.

Additional info:
To be very frank I think it is outrageous to echo passwords in any occasions.
Comment 1 Chris Lumens 2009-02-17 15:56:03 EST
To be very frank, this is not my bug.
Comment 2 Nils Philippsen 2009-02-18 05:38:08 EST
To be very frank, this is already fixed.

*** This bug has been marked as a duplicate of bug 484303 ***

Note You need to log in before you can comment on or make changes to this bug.