Bug 486004 - System-config-services stalls -- all service items are insensitive to any changes.
System-config-services stalls -- all service items are insensitive to any cha...
Status: CLOSED DUPLICATE of bug 467871
Product: Fedora
Classification: Fedora
Component: system-config-services (Show other bugs)
10
i686 Linux
low Severity high
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-17 15:53 EST by Kamil Stawirej
Modified: 2009-02-18 10:23 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-18 10:23:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamil Stawirej 2009-02-17 15:53:21 EST
Description of problem:
System-config-services does not work. When started, the gui shows up, the list of services is loaded, but the application stalls right after that (the cursor is moving, and everything is greyed-out). No changes can be made to any service.

Version-Release number of selected component (if applicable):

Fedora 10
2.6.27.12-170.2.5.fc10.i686

dbus-glib-0.76-3.fc10.i386
dbus-libs-1.2.4-2.fc10.i386
dbus-qt-0.70-4.fc9.i386
dbus-x11-1.2.4-2.fc10.i386
dbus-glib-devel-0.76-3.fc10.i386
ndesk-dbus-0.6.1a-2.fc9.i386
ndesk-dbus-glib-0.4.1-3.fc9.i386
dbus-python-0.83.0-3.fc10.i386
dbus-1.2.4-2.fc10.i386
python-slip-dbus-0.1.15-1.fc10.noarch
dbus-devel-1.2.4-2.fc10.i386
dbus-c++-0.5.0-0.4.20090203git13281b3.fc10.i386

system-config-services-0.99.28-3.fc10.noarch


How reproducible:

ALWAYS

Steps to Reproduce:
1. Run 'system-config-services' from the menu or CLI (as a regular user or root)
2.
3.
  
Actual results:

The application stalls.

Expected results:

I should be able to change the settings of the services.

Additional info:

System-config-services stalls irrespective of whether it is run by a regular user or root. No settings can be changed, the menu works, though.
Comment 1 Nils Philippsen 2009-02-18 05:35:45 EST
Do you have pure-ftpd installed?
Comment 2 Kamil Stawirej 2009-02-18 09:17:06 EST
Yes I have. Can this be the cause of the problem?(In reply to comment #1)
> Do you have pure-ftpd installed?

Yes I do. Can this be the cause?
Comment 3 Nils Philippsen 2009-02-18 10:23:18 EST
(In reply to comment #2)
> > Do you have pure-ftpd installed?
> 
> Yes I do. Can this be the cause?

Yes it is -- pure-ftpd can be run both as a SysV and xinetd service. This is a duplicate of bug #467871, there you can also find some background info.

*** This bug has been marked as a duplicate of bug 467871 ***

Note You need to log in before you can comment on or make changes to this bug.