Bug 486027 - Display is always dimmed to 7 on power event
Display is always dimmed to 7 on power event
Status: CLOSED DUPLICATE of bug 475850
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: hal (Show other bugs)
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: David Zeuthen
Depends On:
  Show dependency treegraph
Reported: 2009-02-17 17:22 EST by Michael Solberg
Modified: 2013-03-05 22:57 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-03-11 12:57:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michael Solberg 2009-02-17 17:22:18 EST
Description of problem:

Every time there's a "power event" like the power chord being unplugged or plugged, my Lenovo T61's display is dimmed to half it's brightness, even though I've set both "ac_brightness" and "battery_brightness" to 100.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Ensure that the following gconf keys are set to 100:
  * /apps/gnome-power-manager/ac_brightness
  * /apps/gnome-power-manager/battery_brightness
2. Either unplug or re-plug the AC.
3. Check brightness in /proc/acpi/ibm/brightness
Actual results:
  * Screen is dim
  * /proc/acpi/ibm/brightness shows a Level of 7

Expected results:
  * Screen is bright
  * /proc/acpi/ibm/brightness shows a Level of 15

Additional info:
  Screen also dims when screensaver activates
Comment 1 Michael Solberg 2009-02-17 17:35:12 EST
Updating platform
Comment 2 Michael Solberg 2009-02-19 10:54:30 EST
Turns out this is actually a problem in HAL.

The property laptop_panel.num_levels is set to 7 on my panel.  If I do this:

hal-set-property --udi /org/freedesktop/Hal/devices/acpi_brightness --key laptop_panel.num_levels --int 15

Then gnome-power-manager behaves as expected.

Comment 3 Richard Hughes 2009-03-11 12:57:09 EDT

*** This bug has been marked as a duplicate of bug 475850 ***

Note You need to log in before you can comment on or make changes to this bug.