Bug 486037 - activationkey.create doesn't throw exception on negative usageLimit
activationkey.create doesn't throw exception on negative usageLimit
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Brad Buckingham
John Matthews
:
Depends On:
Blocks: 456996
  Show dependency treegraph
 
Reported: 2009-02-17 18:14 EST by John Matthews
Modified: 2009-02-25 16:16 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-18 11:11:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Matthews 2009-02-17 18:14:22 EST
Description of problem:

activationkey.create() from the xmlrpc apis, allows a negative "usageLimit" to be passed in.  The docs state "-1" is valid and will be considered as "unlimited".  Assumption is, other negative values would throw an exception.

Prior QA api tests were passing in a value of "-45" and expecting this to throw an exception with wording:
Usage Limit cannot be less than 0.




Version-Release number of selected component (if applicable):
Satellite-5.3.0-RHEL5-re20090213.1-i386-embedded-oracle.iso

How reproducible:
always

Steps to Reproduce:
1. Run test: com.redhat.rhn.rpc.api.activationkey.create::testActivationkeyCreateWithNegativeUsageLimit()
2. Observe no exception is thrown.
3.
  
Actual results:
exception is thrown

Expected results:
no exception thrown, key is set to "unlimited" usage.
Comment 1 John Matthews 2009-02-18 11:11:25 EST
Turns out I had a configuration error in api automation setup and was running against an older ISO.

Closing this as it works as intended with current iso.

Note You need to log in before you can comment on or make changes to this bug.