Bug 486046 - CentOS Kickstarts do not complete in Sat 530
CentOS Kickstarts do not complete in Sat 530
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
530
All Linux
high Severity high
: ---
: ---
Assigned To: Partha Aji
John Matthews
:
Depends On:
Blocks: 457078 486216
  Show dependency treegraph
 
Reported: 2009-02-17 19:54 EST by Jeff Browning
Modified: 2010-05-18 14:16 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530-unconfirmed
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-28 15:49:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Browning 2009-02-17 19:54:39 EST
Description of problem:
After pushing CentOS 5 rpm packages to a custom channel in Sat 530 and building the kickstart tree, the kickstart will not complete. Every time I've tried, it gets to here:

Last File Requested:  	 CentOS/NetworkManager-0.6.4-8.el5.i386.rpm
Total Packages Requested: 	720

and stops. There is no error. The Kickstart just fails to continue any further and has to be canceled.

Version-Release number of selected component (if applicable):
Satellite-5.3.0-RHEL5-re20090213.1-i386-embedded-oracle.iso

How reproducible:
100%

Steps to Reproduce:
1. Create a custom channel in Sat 530 and populate it with the CentOS 5 rpm packages.
2. Build a kickstart tree for that channel.
3. Create a kickstart file for that channel and try to use it to kickstart a system to CentOS 5.
  
Actual results:
As stated above, the kickstart gets to:

Last File Requested:  	 CentOS/NetworkManager-0.6.4-8.el5.i386.rpm
Total Packages Requested: 	720

And then goes no further. It seems to be trying to download more, but it makes no progress and ultimately has to be canceled.

Expected results:
The kickstart should complete without error.

Additional info:
A successful kickstart of a custom CentOS channel like this is part of the NEVRA test plan and therefore must be working before the NEVRA feature can be considered passing.
Comment 1 Jeff Browning 2009-02-17 19:55:55 EST
Added note: The satellite I'm working with right now is fjs-0-01.
Comment 5 John Matthews 2009-02-27 09:23:37 EST
Verified: Satellite-5.3.0-RHEL5-re20090220.1-i386-embedded-orcle.iso

Basic CentOS KS support is working.  The way I tested, I lacked the client tools in a channel for centos client, so the webui didn't show the kickstart status complete.  That wasn't an issue with kickstarts or NEVRA.


Steps to verify:
==Prepare Content on Satellite==
1) Create a custom channel CentOS-52
2) Mount CentOS ISO as /mnt/centos52
3) rhnpush all CentOS rpms to custom channel "CentOS-52"
4) Create a child channel CentOS-52-tools.  
5) rhnpush rhnlib, spacewalk-koan to CentOS-52-tools.  Note:  We should prob add the client tools here as well.
6) On the Satellite, create a dir /ks/centos52-i386
7) Copy /mnt/centos52/images to /ks/centos52-i386
8) Copy /mnt/centos52/repodata to /ks/centos52-i386
9) chmod -R a+rX /ks/centos52-i386 (we need to ensure apache has access to these files, chown -R apache  would prob work too)
==Create Distro===
10) Go into the webui to Kickstart-Distribution
11) Create new distribution
12) Select the base channel of "CentOS-52"
13) For "Tree Path" Enter the directory "/ks/centos52-i386"
14) For Installer Generation I selected "Generic RPM"
15) Create kickstart distribution
==Create KS Profile==
16) Create kickstart profile
17) Go to "Kickstart Details" -> "Operating System" and click the checkbox for the child channel "CentOS-52-tools"
==Prepare client to KS==
18) I started with a RHEL5 client.  If you want to do a CentOS client, you'd need to install the client tools and create an activation key and register it to satellite.  I did not test this path, I tested from RHEL5.
19) edit "/etc/yum/pluginconf.d/rhnplugin.conf   set gpgcheck=0
20) register to Satellite, subscribe to CentOS channel
21) Attempt an install, say yum install zsh
Note:  For the ISO I used I hit a bug in repomd data not being created.  This is a known issue to be fixed in next ISO.  To work around this I edited
/etc/rhn/default/rhn_server.conf 
 # Default to not using taskomatic for repomd
 use_taskomatic_repomd = 0
22) restart satellite:  /usr/sbin/rhn-satellite restart
23) Attempt another yum install zsh on client, you may have to wait 15 mins or so for repo data to be created.  Wait till this succeeds.

At this point everything should be ready to proceed
24) Schedule kickstart to client
25) run rhn_check -vvv  on client
26) reboot client
27) Observe CentOS install

28) The WebUI does not know that the install was finished.  This is because we aren't installing the client tools package.  To clean this up it'd make sense to install the client tools so we could register back to the Satellite.  


While doing this test 1 new bug has been created, bug 487688, this is to note a change in the instructions for ks distro creation in the webui, it needs to mention that repodata must be copied over and the whole dir needs to be readable by apache.

Note You need to log in before you can comment on or make changes to this bug.