Bug 486055 - Evolution doesn't notice ics file
Evolution doesn't notice ics file
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-17 21:10 EST by Jonathan Blandford
Modified: 2013-04-02 00:22 EDT (History)
3 users (show)

See Also:
Fixed In Version: evolution-2.24.4-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-18 13:19:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mail message (30.18 KB, application/octet-stream)
2009-02-18 11:34 EST, Jonathan Blandford
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 567687 None None None Never

  None (edit)
Description Jonathan Blandford 2009-02-17 21:10:18 EST
The attached ICS doesn't seem to be parsed correctly.  It just offers to save it to disk.
Comment 1 Milan Crha 2009-02-18 05:42:18 EST
Can you attach the file, please? ;)
Comment 2 Matthew Barnes 2009-02-18 06:04:32 EST
It's here: http://www.gnome.org/~jrb/files/invite.ics
Comment 3 Milan Crha 2009-02-18 09:48:09 EST
I just tried to import this file to evolution 2.24.3 and it offers me an iCalendar file type, but, because you are talking about Save as, I believe you are doing quite different thing, probably part of some message?

I would suggest two things:
a) check whether itip-formatter plugin is turned on in Edit->Plugins (event if
   it isn't it should show some sort of invitations), and also look in which
   state is your prefer-plain plugin, as well as in Edit->Plugins, then also
   in Edit->Preferences->Mail Preferences, tab HTML Mails

b) is it possible to upload here that mail message?
Comment 4 Jonathan Blandford 2009-02-18 11:33:30 EST
Oh, thought it had attached when I submitted it.  Sorry.

It is attached to a message I received, and I have attached the full message.  The itip-formatter plugin is turned on.  I have "Show HTML if available" set as well.
Comment 5 Jonathan Blandford 2009-02-18 11:34:15 EST
Created attachment 332411 [details]
mail message
Comment 6 Milan Crha 2009-02-18 13:19:44 EST
evolution-2.24.3-1.fc10 doesn't contain patch from the upstream bug [1], whereas evolution-2.24.4-1.fc10 does. You can disable prefer plain plugin (or just move it to any other option than "Show HTML") and it'll start work.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=567687

Note You need to log in before you can comment on or make changes to this bug.