Bug 486062 - openoffice.org isn't registered as being able to handle the mime-types for .pdb .psw .dbf
openoffice.org isn't registered as being able to handle the mime-types for .p...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
desktop-bugs@redhat.com
: Reopened
Depends On: 486086
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-17 22:08 EST by Huangzizhe
Modified: 2010-02-11 09:18 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 486086 (view as bug list)
Environment:
Last Closed: 2009-02-26 06:56:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
the terminal show have installed openoffice.org-javafilter (81.53 KB, image/png)
2009-02-18 03:36 EST, Huangzizhe
no flags Details
the popup window (13.23 KB, image/png)
2009-02-18 03:37 EST, Huangzizhe
no flags Details
assuming that the shared-mime-info addition is good then (3.73 KB, patch)
2009-02-18 05:46 EST, Caolan McNamara
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 20185 None None None Never
OpenOffice.org 109154 None None None Never
OpenOffice.org 99411 None None None Never

  None (edit)
Description Huangzizhe 2009-02-17 22:08:49 EST
Description of problem:
openoffice can't open the file of .pdb  .psw .dbf

Version-Release number of selected component (if applicable):
openoffice.org-core-3.0.0-9.10.fc10.i386

How reproducible:
always

Steps to Reproduce:
1.Get one .pdb  .psw .dbf file 
2.Double click on the file
  
Actual results:
it can't launch openoffice

Expected results:
it can launch openoffice successfully.

Additional info:
These kinds of files were saved by openoffice, if these files can opened by openoffice?
Comment 1 David Tardon 2009-02-18 02:25:37 EST
You need to install openoffice.org-javafilter to be able to open these file formats.
Comment 2 Huangzizhe 2009-02-18 03:34:49 EST
After install openoffice.org-javafilter, These kinds of files still can't opened by openoffice
Comment 3 Huangzizhe 2009-02-18 03:36:39 EST
Created attachment 332347 [details]
the terminal show have installed openoffice.org-javafilter
Comment 4 Huangzizhe 2009-02-18 03:37:37 EST
Created attachment 332348 [details]
the popup window
Comment 5 Caolan McNamara 2009-02-18 04:31:05 EST
Not a great description, but looking at the dialog I can see that its the *nautilus* dialog, so the problem is that openoffice.org isn't get launched to handle those types that it can open.
Comment 6 Caolan McNamara 2009-02-18 04:40:58 EST
dbf is straightforward, we can add application/x-dbf; to calc's desktop. The other two are more difficult as the aportisdoc .pdb is being categorized as "Palm OS Software", so I guess we need to add a new mime type to shared-mime-info and a way to disambiguate from the other .pdb, and then we need to add one to for .psw "Pocket Word" to that. Then we could add those entries to writer's desktop.
Comment 7 Caolan McNamara 2009-02-18 05:29:09 EST
Move to rawhide, as its not very critical
Comment 8 Caolan McNamara 2009-02-18 05:46:31 EST
Created attachment 332354 [details]
assuming that the shared-mime-info addition is good then
Comment 9 Caolan McNamara 2009-02-19 07:08:23 EST
Added .dbf into the calc .desktop, added a .desktop for javafilter to add support for pocketword, pocketexcel and aportis doc when -javafilter is installed. 

Fixed type-detection in office so it will "just do the right thing" when OOo sees those formats

But the .pdb and .psw formats will only work when double clicked on in nautilus when shared-mime-info knows about the application/x-palm-database and application/x-pocket-word, which has been closed upstream to http://bugs.freedesktop.org/show_bug.cgi?id=20185
Comment 10 Caolan McNamara 2009-02-26 06:56:17 EST
Installing openoffice.org-javafilter will now add a 
/usr/share/applications/openoffice.org-javafilter.desktop
with registration for 
application/x-aportisdoc;application/x-pocket-word;application/x-pocket-excel;

So the OOo side is done in rawhide. Unfortunately for nautilus to launch OOo for these types, the shared-mime-info packages needs to know about it too. Patched logged upstream against shared-mime-info and will probably be in the next release of that when it hits rawhide

Note You need to log in before you can comment on or make changes to this bug.