Bug 486071 - failed to import passwords from seamonkey
failed to import passwords from seamonkey
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-18 00:39 EST by Cao, Chen
Modified: 2009-05-06 05:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-06 05:38:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cao, Chen 2009-02-18 00:39:17 EST
Description of problem:
cannot import passwords from seamonkey, while can import 
cookies and bookmarks from seamonkey.


Version-Release number of selected component (if applicable):
firefox-3.1-0.6.beta2.fc11.i386


How reproducible:
100% reproducible


Steps to Reproduce:
1. make sure seamonkey is installed, and visit some sites 
to produce cookies, bookmark some pages, and save some passwords.
and make sure these cookies, bookmarks and passwords are not 
in firefox.
2. clear the cookies, bookmarks and passwords stored in firefox, 
however, this step is optional.
3. launch firefox.
4. open the 'import wizard' by click 'File | import...'.
5. we get importing data from 'Netscape 6, 7 or Mozilla 1.x', and 
click 'Next'.
6. on the page 'Items to import', only select (check) 'saved passwords',
and click 'Next'. then click 'Finish' to complete importing.
7. check the importing result by 
'Edit | Preferences | Security | Saved Passwords...'
  

Actual results:
saved passwords in seamonkey cannot be imported to firefox.


Expected results:
saved passwords in seamonkey can be imported to firefox.


Additional info:
I can import cookies and bookmarks from seamonkey to firefox.
Comment 1 Matěj Cepl 2009-02-27 11:39:34 EST
Having firefox-3.1-0.6.beta2.fc11.x86_64, seamonkey-1.1.14-2.fc11.x86_64, and xulrunner-1.9.1-0.7.beta2.fc11.x86_64 I cannot reproduce this issue. I removed whole ~/.mozilla directory and started seamonkey. Then I have opened seamonkey and browsed to two sites which require authentication (web admin tool for ejabberd in LAN, and bugzilla.redhat.com). Then I have killed seamonkey and started firefox. That asked automatically whether it should import stored content from Netscape, Mozilla 1.* etc. I clicked yes, and both passwords for both sites were stored, history was present, and cookies were visible as well.

Please, provide us with more information about how to reproduce this issue, otherwise I will have to close this bug as unreproducible.
Comment 2 Martin Stransky 2009-05-06 05:38:00 EDT
closing as WORKSFORME.

Note You need to log in before you can comment on or make changes to this bug.