Bug 486076 - setup-ds-admin.pl does not work properly
setup-ds-admin.pl does not work properly
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: UI - Configuration (Show other bugs)
1.1.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nathan Kinder
Chandrasekar Kannan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-18 02:09 EST by The Source
Modified: 2015-01-04 18:36 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-06 17:20:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Script output with -ddd (4.04 KB, application/x-bzip2)
2009-03-05 01:38 EST, The Source
no flags Details

  None (edit)
Description The Source 2009-02-18 02:09:41 EST
Description of problem:
This script can't process 'suggest' option - if I choose it, it complains that it can find /tmp/something-or-other.ldif. Does it forget to generate ldif file? I also can not load even Example.ldif from official fedora-ds packages (Fedora 10), error 65280 pops up without any explanation (I modified this file a little - example.com to my domain). This happens with any ldif. I have openldap packages installed including server. I run the script as root.

Version-Release number of selected component (if applicable):
fedora-ds-admin-1.1.6, fedora-ds-1.1.2

How reproducible:
always

Steps to Reproduce:
1.Launch the script and get to suggest/none/path step
2.Choose suggest to see the error of non-existent file
3.Enter specific path to see error 65280.
  
Actual results:


Expected results:


Additional info:
Comment 1 Rich Megginson 2009-02-20 10:18:40 EST
What version of fedora-ds-base? rpm -qi fedora-ds-base
What are the exact error messages you see?  Can you run setup-ds-admin.pl -ddd to generate more debugging information?
Comment 2 Nathan Kinder 2009-03-03 13:01:26 EST
I am unable to reproduce this issue.

Are you running the setup script as root?  The user you are running setup as needs to be able to create a file in /tmp.  It will then change the permissions of this file to be accessible by the user you are running ns-slapd as.  I'm guessing that the file creation is what is failing.
Comment 3 The Source 2009-03-03 13:40:51 EST
Yes, I'm running it as root. Besides, /tmp has write permissions for everyone anyway.
Comment 4 Nathan Kinder 2009-03-03 14:23:50 EST
(In reply to comment #3)
> Yes, I'm running it as root. Besides, /tmp has write permissions for everyone
> anyway.

ok.  I'd like to see the debug output from the setup script that Rich mentioned (use the -ddd option).  In my test, I see a this section where it updates the permissions on the LDIF file:

+changeOwnerMode: changed mode of /tmp/ldifXM2lg8.ldif to 440
+changeOwnerMode: changed ownership of /tmp/ldifXM2lg8.ldif to user 99 group 99
+importing data ...
Comment 5 The Source 2009-03-05 01:37:18 EST
Hmm, I ran the script on a fresh-installed fedora and now importing went smoothly. However script never exits. I attached script output. The last line is about starting directory server. After that line script just stays in terminal.
Comment 6 The Source 2009-03-05 01:38:10 EST
Created attachment 334100 [details]
Script output with -ddd
Comment 7 The Source 2009-03-05 01:38:56 EST
Oh, by the way, fedora-ds-base version is 1.1.3
Comment 8 The Source 2009-03-05 01:39:55 EST
Oops, script finally exited:

'.  Error: Unknown error 256
Error: Could not create directory server instance 'thesource'.
Exiting . . .
Log file is '/tmp/setupPHdqfQ.log'
Comment 9 The Source 2009-03-05 01:41:03 EST
Sorry, here's full text:

Possible timeout starting server: timeout=1236235161 now=1236235162
Could not start the directory server using command '/usr/lib/dirsrv/slapd-thesource/start-slapd'.  The last line from the error log was '[05/Mar/2009:09:29:22 +0300] - Fedora-Directory/1.1.3 B2008.289.115 starting up
'.  Error: Unknown error 256
Error: Could not create directory server instance 'thesource'.
Exiting . . .
Log file is '/tmp/setupPHdqfQ.log'
Comment 10 Rich Megginson 2009-04-06 17:20:44 EDT
Try fedora ds 1.2.0 - just released today - if you still have the problem, please reopen the bug

Note You need to log in before you can comment on or make changes to this bug.