Bug 486139 - mount.ecryptfs cannot un-mount ~/Private on shutdown
mount.ecryptfs cannot un-mount ~/Private on shutdown
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: ecryptfs-utils (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Michal Hlavinka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-18 11:31 EST by Piergiorgio Sartor
Modified: 2009-04-09 12:14 EDT (History)
4 users (show)

See Also:
Fixed In Version: 73-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-09 12:14:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Piergiorgio Sartor 2009-02-18 11:31:10 EST
Description of problem:
On shutdown, from gnome menu, i.e. without direct logout, with ~/Private mounted, the system keep shouting about not being able to umount ~/Private.
The reported error is, among others, that "mount.ecryptfs" cannot load shared object "libecryptfs.so.0".

Version-Release number of selected component (if applicable):
ecryptfs-utils-70-1.fc10

How reproducible:
Almost always, maybe there is some race condition. See below.

Steps to Reproduce:
1.
Mount ~/Private (with ecryptfs) either manually or automatically (pam login setup).
2.
Shutdown from within the graphical user interface using the proper menu entry.
  
Actual results:
Almost always the system, when reaching the point where it umounts the different filesystems, keeps complaining that ~/Private and /home (I guess) cannot be umounted and that "mount.ecryptfs" cannot load shared object "libecryptfs.so.0".

Expected results:
Everything should be umounted properly.

Additional info:
The issue might be caused by the fact that /usr could be umounted before /home and /usr/lib{arch}/libecryptfs.so.0 is not available anymore.
If this is the case, the possible solutions could be:

1) link mount.ecryptfs statically
2) move libecryptfs.so.0 to /lib

Thanks,

piergiorgio
Comment 1 Michal Hlavinka 2009-03-21 03:33:00 EDT
fixed in ecryptfs-utils-73-1.fc10 and ecryptfs-utils-73-1.fc11
Comment 2 Fedora Update System 2009-03-21 05:24:43 EDT
ecryptfs-utils-73-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/ecryptfs-utils-73-1.fc10
Comment 3 Piergiorgio Sartor 2009-03-21 05:41:42 EDT
I made just one quick test and I could not see the problem anymore, so it seems fixed.

Thanks also for this one!

pg
Comment 4 Fedora Update System 2009-03-23 11:52:27 EDT
ecryptfs-utils-73-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ecryptfs-utils'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2913
Comment 5 Fedora Update System 2009-04-09 12:13:57 EDT
ecryptfs-utils-73-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.