This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 486166 - ALSA drivers (hda-intel and ice1724) failing to load in current Rawhide
ALSA drivers (hda-intel and ice1724) failing to load in current Rawhide
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-18 12:54 EST by Adam Williamson
Modified: 2009-02-28 12:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-28 12:11:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2009-02-18 12:54:58 EST
After upgrading my system to Rawhide I noticed that the sound drivers for two of my audio devices are failing to load: snd-hda-intel and snd-ice1724. I see these messages in /var/log/messages :

Feb 17 14:03:15 adam kernel: ALSA sound/core/init.c:183: cannot find the slot for index 1 (range 0-1), error: -16
Feb 17 14:03:15 adam kernel: ALSA sound/pci/hda/hda_intel.c:2340: hda-intel: Error creating card!
Feb 17 14:03:15 adam kernel: ALSA sound/core/init.c:183: cannot find the slot for index 0 (range 0-1), error: -16
Feb 17 14:03:15 adam kernel: HDA Intel: probe of 0000:00:1b.0 failed with error -12
Feb 17 14:03:15 adam kernel: ICE1724: probe of 0000:05:01.0 failed with error -12

the snd-usb-audio module *does* load, though, and the USB audio devices I have connected seem to be working.

This is since at least 2.6.29-0.99.rc4.git1.fc11, but it may actually have been earlier than that. It persists with the kernel I'm running now, 2.6.29-0.124.rc5.fc11 . This is an x86-64 install. My hardware profile is:

http://www.smolts.org/show?uuid=pub_84465125-1350-4f83-87b9-5f16f7430eb8

Both cards worked fine in F10.
Comment 1 Chuck Ebbert 2009-02-26 22:24:21 EST
Can you post the contents of /proc/asound/cards after the system boots?
Comment 2 Adam Williamson 2009-02-27 18:26:11 EST
Oh, sorry, I should've mentioned that. Already did it. The cards aren't listed there, so obviously things are fairly broken:

[adamw@adam ~]$ cat /proc/asound/cards 
 0 [Webcam         ]: USB-Audio - Rocketfish 2MP AF Webcam
                      Rocketfish Rocketfish 2MP AF Webcam at usb-0000:00:1d.7-3, high speed
 1 [default        ]: USB-Audio - Microsoft LifeChat LX-3000 
                      Microsoft LifeChat LX-3000  at usb-0000:00:1d.1-2, full speed
[adamw@adam ~]$

Those are just my USB audio devices. There should be two more entries for the snd-hda-intel and snd-ice1724 handled devices.

This is with 2.6.29-0.148.rc6.fc11.x86_64 , now. It's been broken with every kernel since the initial report.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Chuck Ebbert 2009-02-28 00:39:24 EST
(In reply to comment #2)
> 
> [adamw@adam ~]$ cat /proc/asound/cards 
>  0 [Webcam         ]: USB-Audio - Rocketfish 2MP AF Webcam
>                       Rocketfish Rocketfish 2MP AF Webcam at
> usb-0000:00:1d.7-3, high speed
>  1 [default        ]: USB-Audio - Microsoft LifeChat LX-3000 
>                       Microsoft LifeChat LX-3000  at usb-0000:00:1d.1-2, full
> speed

Is there some config file in /etc/modprobe.d that is trying to force the two drivers that fail to load into slots 0 and 1? If the two usb drivers load first that isn't going to work...
Comment 4 Adam Williamson 2009-02-28 12:01:17 EST
Oh. Good catch. I'd forgotten about it, but yes, there is - I need that so I can reliably tell PulseAudio how to use the digital output on the ice1724 card:

options snd_hda_intel index=1
options snd_ice1724 index=0

I guess the USB module is now getting loader sooner, somehow. I'll check that it works without that file (and if I set them to 2 and 3), and close as INVALID if so. Thanks.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Adam Williamson 2009-02-28 12:11:16 EST
Confirmed - set to index=2 and index=3 and it works. Thanks for the good guess, sorry for the time.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.