Bug 486186 - Update spacewalk spec files to require cobbler >= 1.4.2
Update spacewalk spec files to require cobbler >= 1.4.2
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
0.5
All Linux
low Severity medium
: ---
: ---
Assigned To: Mike McCune
Jesus M. Rodriguez
:
Depends On:
Blocks: space05 swcobbler05
  Show dependency treegraph
 
Reported: 2009-02-18 14:37 EST by Mike McCune
Modified: 2012-03-06 04:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-17 03:10:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McCune 2009-02-18 14:37:37 EST
1.4.2 includes a good auth fix and other bugs that we want to pull down for spacewalk.
Comment 1 Mike McCune 2009-02-18 14:37:58 EST
likewise, koan >= 1.4.2
Comment 2 Michael DeHaan 2009-02-18 14:38:48 EST
The auth fix will actually be in 1.4.3

Though we'll need to bump to that eventually as well.

This bugzilla should also result in koan being required as >=1.4.2
Comment 3 Dave Parker 2009-02-18 16:11:08 EST
[root@spacewalk spacewalk{bz486186}]$ find -name '*.spec' -exec grep -HEi 'requires:.*(cobbler|koan)' {} \;
./client/tools/spacewalk-koan/spacewalk-koan.spec:Requires:       koan >= 1.2.6
./client/tools/spacewalk-koan/spacewalk-koan.spec:Requires: koan
./java/spacewalk-java.spec:Requires: cobbler >= 0:1.4
./java/spacewalk-java.spec:Requires: cobbler >= 0:1.4
./backend/spacewalk-backend.spec:Requires: cobbler >= 0:1.4
./spacewalk/setup/spacewalk-setup.spec:Requires:       cobbler >= 0:1.4

Changed to:

[root@spacewalk spacewalk{bz486186}]$ find -name '*.spec' -exec grep -HEi 'requires:.*(cobbler|koan)' {} \;
./client/tools/spacewalk-koan/spacewalk-koan.spec:Requires:       koan >= 1.4.2
./java/spacewalk-java.spec:Requires: cobbler >= 1.4.2
./java/spacewalk-java.spec:Requires: cobbler >= 1.4.2
./backend/spacewalk-backend.spec:Requires: cobbler >= 1.4.2
./spacewalk/setup/spacewalk-setup.spec:Requires:       cobbler >= 1.4.2


[root@spacewalk noarch]$ rpm -qp --requires *.rpm | grep -iE '(cobbler|koan)'
cobbler >= 1.4.2
cobbler >= 1.4.2
config(spacewalk-koan) = 0.1.8-1.git.586ccf85656dc3140ec41b1927b2a2e7fcafa68e
koan >= 1.4.2
cobbler >= 1.4.2
cobbler >= 1.4.2


In commit 586ccf85656dc3140ec41b1927b2a2e7fcafa68e I note the following:

Changed required version number to 1.4.2 for both KOAN and Cobbler per bz486186

Note that in java/spacewalk-java.spec in particular there remains some odd (IMO) syntax wrt Requires statements:   One sees 'Requires: <pkg> >= 0:<some version>'

I've come across no documentation for this.  mpdehaan said he suspects (but is not certain) that it's related to "epoch" but is regardless firmly of the belief that it has no proper place in relation to cobbler or koan.

I'm leaving other occurences of the 0:<blah> syntax in place for lack of a better understanding.  Hopefully someone will have some context at some point - it'd be nice to know what's meant by this (or at least why it is that the spec files are in fact building at all).
Comment 4 Mike McCune 2009-03-09 10:26:28 EDT
Gotta go again to 1.4.3.
Comment 5 Mike McCune 2009-03-19 00:08:12 EDT
bumped to 143
Comment 6 Mike McCune 2009-03-23 17:19:54 EDT
ON_QA
Comment 7 Jesus M. Rodriguez 2009-04-14 10:13:10 EDT
Spacewalk 0.5 released.
Comment 8 Miroslav Suchý 2009-09-17 03:10:29 EDT
Spacewalk 0.5 has been released for long time ago.

Note You need to log in before you can comment on or make changes to this bug.