Bug 486192 - Evolution crashes randomly (especially when hitting junk button)
Evolution crashes randomly (especially when hitting junk button)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
10
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-18 14:46 EST by Bryan Christ
Modified: 2009-03-09 10:53 EDT (History)
5 users (show)

See Also:
Fixed In Version: evolution-2.24.5-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-09 10:53:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Crash info from Bug Buddy (18.07 KB, text/plain)
2009-02-19 13:49 EST, Bryan Christ
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 569700 None None None Never

  None (edit)
Description Bryan Christ 2009-02-18 14:46:27 EST
Description of problem:

Evolution crashes randomly.  This happens frequently when hitting the junk button but also happens with other normal operation functions.

Version-Release number of selected component (if applicable):


How reproducible: once per hour


Steps to Reproduce:
1.  Update evolution to version evolution-2.24.4-1.fc10 from updates-testing
2.  Use IMAP email
3.  Should crash at least once every hour
  

Additional info:

This did not happen on the previous version of the software which was released through the updates repository.
Comment 1 Milan Crha 2009-02-18 15:08:21 EST
Thanks for the bug report, can you upload here traces from bug-buddy, so we can look where it crashed? (It doesn't crash to me, also with an IMAP account.)
Comment 2 Bryan Christ 2009-02-18 16:12:29 EST
I would be glad to.  I have bug-buddy installed, but can you give me some instructions on how to make sure it is running.  I have looked in services and sessions and cannot find the "correct" way to run bug-buddy.
Comment 3 Matthew Barnes 2009-02-18 16:52:10 EST
Bug Buddy should trigger automatically when Evolution crashes.  The key is to make sure the trace it produces contains debugging symbols so we can make sense of the data.

Run this command as root before you capture the traces:

   debuginfo-install evolution
Comment 4 Bryan Christ 2009-02-19 13:49:13 EST
Created attachment 332609 [details]
Crash info from Bug Buddy
Comment 5 Milan Crha 2009-02-20 05:12:58 EST
This particular crash had been fixed recently, a bit more than week ago, within an upstream bug [1]. As a workaround, you can disable loading images in mail in Edit->Preferences->Mail Preferences, tab HTML Messages, section Load Images, choose Never load images from Internet. The fix will be included in 2.24.5, which will upstream release near February 25th.

When you disable remote image loading, do you see other crashers too?

[1] http://bugzilla.gnome.org/show_bug.cgi?id=569700
Comment 6 Bryan Christ 2009-02-20 10:41:47 EST
Milan,

The Gnome team informed me that this is indeed fixed in a new release.  I will try running with image loading turned off.  If there are no crashes for the day I will assume that this was the already known problem.

What would be the ETA for getting 2.24.5 pushed out to the updates-testing repository?
Comment 7 Matthew Barnes 2009-02-20 10:52:40 EST
Once 2.24.5 is released and packaged for Fedora, it'll take a day or two to push it to updates-testing.  So end of next week would be my guess.
Comment 8 Bryan Christ 2009-02-20 18:05:17 EST
With image loading turned off, Evolution ran all day without a single crash.
Comment 9 Craig White 2009-02-22 19:20:50 EST
2.24.4-1 crashes as soon as you click 'Print'

This is a bad release
Comment 10 Craig White 2009-02-22 19:33:22 EST
and for the record, I get a segmentation fault even though I changed the setting to 'Never load images' as indicated above. I'm not all that enthusiastic about running debug version of evolution...it wanted to install 41 packages.

Also, others now have found the same issue on fedora-list, now that you've pushed out the update... https://www.redhat.com/archives/fedora-list/2009-February/msg02442.html
Comment 11 John Mellor 2009-02-25 19:36:28 EST
Why is this very-high-visibility bug marked low-priority?
I know that myself, I have submitted at least a dozen crashes now.  I see lots of noise about many other users with identical problems, so its pretty widespread.
It should be the highest priority on the owner's queue...
Comment 12 Mike Chambers 2009-03-07 10:39:04 EST
(In reply to comment #11)
priority levels aren' looked at or used by maintainers really.  Just because you or I see it as important, doesn't mean the maintainer does, as you don't know what is on his plate at the moment, and maybe something else is even bigger.  Anyway, this has been fixed in the latest version, just waiting for it to be released and packaged for Fedora.  Look for 2.24.5 for the fix.  Please confirm the fix once you haved updated the package and report back as fixed or not, as well as close the bug if so.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 13 John Mellor 2009-03-07 11:08:30 EST
Test report: Fixed in evolution-2.24.5-1.fc10.i386

I have not had an evolution crash since the new version came out.
Comment 14 Bryan Christ 2009-03-09 10:25:45 EDT
Ditto to comment #13.  Seems fixed to me.
Comment 15 Matthew Barnes 2009-03-09 10:53:30 EDT
(In reply to comment #12)
> priority levels aren' looked at or used by maintainers really.  Just because
> you or I see it as important, doesn't mean the maintainer does, as you don't
> know what is on his plate at the moment, and maybe something else is even
> bigger.

That's correct.  Because those fields are changable by anyone, maintainers ignore them.  Unfortunate, really, because they -could- be useful.

Anyway, closing as fixed since we have two confirmations now.  Thanks for the updates, guys.  If you see it happen again feel free to reopen the bug.

Note You need to log in before you can comment on or make changes to this bug.