Bug 486209 - kernel BUG at mm/highmem.c:320
kernel BUG at mm/highmem.c:320
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-02-18 16:21 EST by Bill McGonigle
Modified: 2009-12-18 02:57 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-12-18 02:57:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
kernel trace (2.96 KB, text/plain)
2009-02-18 16:21 EST, Bill McGonigle
no flags Details

  None (edit)
Description Bill McGonigle 2009-02-18 16:21:09 EST
Created attachment 332455 [details]
kernel trace

Description of problem:

  kernel panic

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. boot system
2. wait a moment
3. panic
Actual results:


Expected results:

  no panic

Additional info:

  In the attachment you'll see hal-acl-tool in the trace, but this happens with many seemingly random apps, this was just a trace I was able to capture.

  It seems highly correlated with my having the machine running with the PCI video card (nvidia GeForceMX 4000) as the primary card.  If I switch it to the integrated video as the primary, I think it goes away.  Or at least it happens with such infrequency as I haven't noticed it.  In both cases both are active, just which the BIOS thinks is primary is swapped.

  This is on an Intel server board with a Core2Duo CPU.  Let me know what else I can post to help.

  It's also new to Fedora 10.  I was previously running Fedora 8 without this problem.
Comment 1 Chuck Ebbert 2009-02-18 17:31:31 EST

Can you reproduce that without the nvidia driver, i.e. using nv or nouveau?
Comment 2 Bill McGonigle 2009-02-19 04:04:04 EST
Oh, sorry, I should have said this is currently running in runlevel 3.  I'm having separate problems with X at the moment.
Comment 3 Chuck Ebbert 2009-02-19 18:27:22 EST
the nvidia kernel driver could still cause problems if it's loaded but not being used.
Comment 4 Bill McGonigle 2009-02-19 20:35:37 EST
Ah, OK, thanks Chuck.  I'll back it out and retest.
Comment 5 Bill McGonigle 2009-02-20 13:06:48 EST
I removed the nvidia kmods and still get this, with the same trace.

I've never see it in single user mode, so I tried starting up in 'interactive' runlevel 3 and disabled all the services, which I thought also stopped this, but just when I thought I'd narrowed down the service by binary search, I was proven wrong with a panic.  So single user mode could just show that it doesn't happen when not much is going on.

Part of the trick is here is I'm trying to prove the negative at each iteration and my only testcase is 'get lots of stuff running on each vc' which is pretty poor on time.  Does the trace suggest anything to you that could help me come up with a better test?

If I had that I could do some more effective troubleshooting.
Comment 6 Bill McGonigle 2009-07-27 12:29:11 EDT
FWIW, this machine was redeployed as a server about 3 months ago and this does not occur without the PCI video card set as primary.  I can't really test at this point since that server is in production.
Comment 7 Bug Zapper 2009-11-18 04:51:56 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 8 Bug Zapper 2009-12-18 02:57:37 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.