Bug 486225 - ping -R option emits 'record route: No message of desired type'
ping -R option emits 'record route: No message of desired type'
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-18 17:21 EST by Michael Cronenworth
Modified: 2009-02-22 15:04 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-22 15:04:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Cronenworth 2009-02-18 17:21:31 EST
Description of problem: When I attempt to use the '-R' command line argument option for 'ping' I receive a message instead of the expected ping results. This occurs on Fedora 10. Rawhide and Fedora 9 are apparently not affected. This is not specific to a unique DNS name or IP address. It occurs with any IP or DNS name given. SELinux set to enforced and then permissive. No change.


Version-Release number of selected component (if applicable): kernel-2.6.27.12-170.2.5.fc10, iputils-20071127-6.fc10


How reproducible: Always


Actual results:
$ ping -R intranet
  ping: record route: No message of desired type

Expected results:
$ ping -R intranet
  PING intranet.cchtml.com (10.0.0.1) 56(124) bytes of data.
  64 bytes from 10.0.0.1: icmp_seq=1 ttl=65 time=0.091 ms
  RR: 	10.0.0.1
 	10.0.0.1
 	10.0.0.1
 	10.0.0.1


Additional info: Mailing list reference: https://www.redhat.com/archives/fedora-test-list/2009-February/msg00776.html
Comment 1 Kyle McMartin 2009-02-18 17:28:07 EST
Just for the record, rawhide is affected, but seemingly only i386, not x86_64.

cheers, Kyle
Comment 2 Kyle McMartin 2009-02-19 16:30:43 EST
Could you please try the scratch build available here when it's finished http://koji.fedoraproject.org/koji/taskinfo?taskID=1140959?

regards, Kyle
Comment 3 Michael Cronenworth 2009-02-19 18:55:54 EST
That kernel works great. Thanks, Kyle and friends.
Comment 4 Mihai Harpau 2009-02-20 09:39:06 EST
Hi,
For me kernel-2.6.27.19-170.2.29.rc1.fc10 does not resolve the issue (on PAE-i686 and x86_64):

[mihai@taz ~]$ ping -R localhost
ping: record route: No message of desired type
[mihai@taz ~]$ uname -a
Linux taz 2.6.27.19-170.2.29.rc1.fc10.x86_64 #1 SMP Wed Feb 18 18:07:29 EST 2009 x86_64 x86_64 x86_64 GNU/Linux

and

[mihai@sysop ~]$ ping -R localhost
ping: record route: No message of desired type
[mihai@sysop ~]$ uname -a
Linux sysop 2.6.27.19-170.2.29.rc1.fc10.i686.PAE #1 SMP Wed Feb 18 18:17:56 EST 2009 i686 i686 i386 GNU/Linux

The same problem appears on kernel-2.6.27.19-170.2.24.fc10 (PAE-i686 and x86_64).
Comment 5 Kyle McMartin 2009-02-20 16:42:29 EST
Mihai, are you sure you're running the correct build of the kernel? I've confirmed it fixed on both i686-PAE and x86_64...

That said, Paul Moore has updated the patch, so if you could try the scratchbuild here (sorry I failed to set buildid sensibly last time...) that would be great.

http://koji.fedoraproject.org/koji/taskinfo?taskID=1143272

Thanks in advance, Kyle
Comment 6 Mihai Harpau 2009-02-21 03:27:02 EST
Sorry, I think I was wrong because the kernels from first URL have the same name with those from http://koji.fedoraproject.org/koji/buildinfo?buildID=83287 :)
Ok, I will try the kernels from last URL and come back with results.
Comment 7 Mihai Harpau 2009-02-22 11:33:13 EST
I can confirm that kernels from http://koji.fedoraproject.org/koji/taskinfo?taskID=1143272 fixed the bug. Thanks.
Comment 8 Kyle McMartin 2009-02-22 15:04:19 EST
Great, thanks for testing. I can confirm this as well. I've committed it to the Fedora kernel on the rawhide, F-10, F-10-2.6.27 and F-9-2.6.27 branches, and it will be in the next upload of each them respectively.

Marking closed.

cheers, Kyle

Note You need to log in before you can comment on or make changes to this bug.