Bug 486228 - [LTC 6.0 FEAT] 201857: Kernel vdso support
[LTC 6.0 FEAT] 201857: Kernel vdso support
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
s390x All
low Severity high
: rc
: 6.0
Assigned To: Red Hat Kernel Manager
Martin Jenner
: FutureFeature
Depends On:
Blocks: 356741
  Show dependency treegraph
 
Reported: 2009-02-18 17:30 EST by IBM Bug Proxy
Modified: 2010-04-29 06:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-22 17:19:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 51760 None None None Never

  None (edit)
Description IBM Bug Proxy 2009-02-18 17:30:31 EST
=Comment: #0=================================================
Hans-Georg Markgraf <mgrf@de.ibm.com> - 
1. Feature Overview:
Feature Id:	[201857]
a. Name of Feature:	Kernel vdso support
b. Feature Description
Add vdso support to speed up gettimeofday, clock_getres and clock_gettime. The gettimeofday system
call needs two things to come up with the correct time: 1) the content of the TOD clock and 2) the
current system time offset. The store clock (STCK) instruction can be used in a user space
application but the current system time offset is only known to the kernel. The vdso shared object
is a kernel provided shared library that contains the system time offset and the code to do the
gettimeofday calculation in user space. The same holds true for the clock_getres and the
clock_gettime calls.

2. Feature Details:
Sponsor:	zSeries
Architectures:
s390x

Arch Specificity: Purely Arch Specific Code
Affects Core Kernel: Yes
Delivery Mechanism: Direct from community
Category:	Kernel
Request Type:	Kernel - Enhancement from IBM
d. Upstream Acceptance:	Accepted
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	K 2.6.29

3. Business Case
Some user space application, for example the Java virtual machine, tend to call gettimeofday very
often. By use of a vdso this operation can be accelerated by an factor of 4 thereby increasing the
performance of the user space application.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com, Boeblingen 49-7031-16-3978

Technical contact(s):
Gonzalo Muelas Serrano, gmuelas@de.ibm.com

IBM Manager:
Thomas Schwarz, t.schwarz@de.ibm.com
Comment 1 Bill Nottingham 2009-02-26 11:52:39 EST
Since this has been accepted into 2.6.29, and RHEL 6 will include at least 2.6.29, marking as MODIFIED.

The feature requested has already been accepted into the upstream code base
planned for the next major release of Red Hat Enterprise Linux.

When the next milestone release of Red Hat Enterprise Linux 6 is available,
please verify that the feature requested is present and functioning as
desired.
Comment 2 Hans-Joachim Picht 2009-09-22 17:19:13 EDT
Code is included in the rhel6 kernel via upstream. Marked as
CLOSED/CURRENTRELEASE by Hans-Joachim Picht <hpicht@redhat.com>
Comment 3 IBM Bug Proxy 2010-04-29 06:11:15 EDT
------- Comment From mgrf@de.ibm.com 2010-04-29 06:00 EDT-------
This feature is successful tested on R6 beta1
Set feature to "verified"     - Thx-

Note You need to log in before you can comment on or make changes to this bug.