Bug 486239 - drag and drop broken on desktop
drag and drop broken on desktop
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-18 19:02 EST by J Chapin
Modified: 2009-02-18 23:18 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-18 23:04:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description J Chapin 2009-02-18 19:02:19 EST
Description of problem:

Dragging a file creates a copy rather than moves the file

Version-Release number of selected component (if applicable):


How reproducible:

100%

Steps to Reproduce:
1. click and drag icon over
2. drop
3.
  
Actual results:

2 copies of the icon

Expected results:

icon to move

Additional info:
Comment 1 Rex Dieter 2009-02-18 19:08:54 EST
To be clear, are you talking about icons on the plasma desktop, or icons within a FolderView, or something else?
Comment 2 J Chapin 2009-02-18 19:17:15 EST
icons located on the desktop/ that are located in the ~/Desktop directory.
Comment 3 Rex Dieter 2009-02-18 19:34:58 EST
ok, I can't reproduce that, works fine here.  :(
Comment 4 Kevin Kofler 2009-02-18 19:39:00 EST
Hold Shift when dragging to move files in places where copy is the default.
Comment 5 J Chapin 2009-02-18 22:35:09 EST
So is the bug the fact that copy is the default, then?
Comment 6 Kevin Kofler 2009-02-18 22:41:40 EST
From where to where are you dragging stuff? Is the ~/Desktop folder view the target? What's the source? Are you sure you're dragging to ~/Desktop and not to the plasma desktop itself? (Hint: Plasma's default desktop is NOT the ~/Desktop folder. If you want to use the ~/Desktop folder, you have to either use a folder view applet/widget/plasmoid or to set your desktop activity to Folder view instead of Desktop in the dettings.)
Comment 7 J Chapin 2009-02-18 22:49:27 EST
No, I am not sure. 

Looking at an otherwise blank desktop, I have some icons. I select one of these and move it six inches to the right. I now have 2 identical icons. Default behavior of drag and drop (unless you are crossing a drive/partition boundary) is to move, not copy, ergo not doing that is a bug. I don't care if it is changing directories, update the inode and move the damn file.
Comment 8 Kevin Kofler 2009-02-18 23:04:28 EST
Can you attach a screenshot of your desktop and clearly indicate from where to where you're dragging the icon?

I cannot reproduce this behavior with a plasmoid nor with a folder view, unless I try to drag the icon from inside the folder view to outside the folder view. If that's what you're doing, then the behavior is fully expected. When using the default desktop (not the folder view as desktop), icons outside the folder view are NOT files, they're plasmoids which are merely links. So you cannot move a file from your ~/Desktop folder (inside your folder view) to there, you can only link it.

If you want a traditional desktop behavior:
1. right-click, Appearance settings, choose Folder view instead of Desktop, click OK and
2. remove the folder view widget (otherwise you have 2 views of the same folder, which makes no sense).
Comment 9 J Chapin 2009-02-18 23:18:05 EST
So by 'expected behavior', what you really mean is 'completely different than what is expected by a normal user'?

Note You need to log in before you can comment on or make changes to this bug.