Bug 486252 - KDE4.2 cannot show Chinese fonts after using anti-aliasing
KDE4.2 cannot show Chinese fonts after using anti-aliasing
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: wqy-bitmap-fonts (Show other bugs)
10
i686 Linux
low Severity high
: ---
: ---
Assigned To: Qianqian Fang
Fedora Extras Quality Assurance
: Desktop, i18n, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-18 21:33 EST by yd.nvstp
Modified: 2009-09-21 17:33 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-06 01:22:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
steps to reproduce the bug (99.24 KB, image/png)
2009-02-20 02:32 EST, yd.nvstp
no flags Details

  None (edit)
Description yd.nvstp 2009-02-18 21:33:05 EST
Description of problem:

I use Fedora10. And update to KDE4.2 by using yum.
It can show chinese fonts when I didn't install kde-l10n-Chinese package.
But it cannot show chinese fonts after I install the kde-l10n-Chinese package.
When I remove the chinese package, it works well again.
So I think there is something wrong about the kde-l10n-Chinese package.

Version-Release number of selected component (if applicable):
Fedora 10
KDE 4.2

How reproducible:
install kde-l10n-Chinese package

Steps to Reproduce:
1. update to KDE4.2 in Fedora10
2. install kde-l10n-Chinese package
3. open a browser and open a chinese site, such as www.sina.com.cn
  
Actual results:
KDE show blank space where chinese fonts exist

Expected results:
KDE can show chinese fonts well

Additional info:
Comment 1 Yijun Yuan 2009-02-19 01:32:56 EST
I've no idea about this problem as I don't use KDE, but I'd interested to try it. According to Dingyi [1], there is some font preference problem. As this kind of Qt bugs happen since the start of KDE project, while Red Hat / Fedora managed to prevent such behavior in former releases, I believe a patch got dropped incorrectly in the new release.



[1] http://dingyichen.livejournal.com/9674.html
Comment 2 yd.nvstp 2009-02-19 01:54:40 EST
(In reply to comment #1)
> I've no idea about this problem as I don't use KDE, but I'd interested to try
> it. According to Dingyi [1], there is some font preference problem. As this
> kind of Qt bugs happen since the start of KDE project, while Red Hat / Fedora
> managed to prevent such behavior in former releases, I believe a patch got
> dropped incorrectly in the new release.

Maybe.

I also use Archlinux in my notebook, but there is not such problem about KDE4.2.
So I think this problem is about fedora.
> 
> 
> 
> [1] http://dingyichen.livejournal.com/9674.html
Comment 3 Tommy He 2009-02-19 02:52:52 EST
Unfortunately, I am unable to reproduce this bug.

What I did is :

1. Freshly install a Fedora 10 from Fedora-10-Live-KDE-i686
2. Upgrade KDE to 4.2 via su -c 'yum update kde*'
3. Because the default locale set of KDE LiveCD is en_US, I suppose the correct LANG environment variable is necessary: Changing the first line in /etc/sysconfig/i18n from LANG="en_US.UFT-8" to LANG="zh_CN.UTF-8" .
4. Install the KDE Language Pack via su -c 'yum install kde-l10n-Chinese'
5. Reboot the system.

Then the whole KDE interface was displayed in Chinese after login. I used Konqueror as the browser (Firefox is not installed by default under KDE LiveCD)to test the websites below:
 http://www.sina.com.cn   Kind of slow due to the lack of Flash plugin, but all Chinese characters were correctly rendered.
 http://www.google.cn     Perfectly displayed.


From the reproduce steps I did above, I would like to say this could not be a problem about Fedora.
Comment 4 yd.nvstp 2009-02-19 05:41:18 EST
Very strange thing! I cannot reproduce the bug either now.
Maybe I updated my system yesterday. It works well now.

But I have reproduced this bug on two different PCs.

Anyway, thank you.

(In reply to comment #3)
> Unfortunately, I am unable to reproduce this bug.
> 
> What I did is :
> 
> 1. Freshly install a Fedora 10 from Fedora-10-Live-KDE-i686
> 2. Upgrade KDE to 4.2 via su -c 'yum update kde*'
> 3. Because the default locale set of KDE LiveCD is en_US, I suppose the correct
> LANG environment variable is necessary: Changing the first line in
> /etc/sysconfig/i18n from LANG="en_US.UFT-8" to LANG="zh_CN.UTF-8" .
> 4. Install the KDE Language Pack via su -c 'yum install kde-l10n-Chinese'
> 5. Reboot the system.
> 
> Then the whole KDE interface was displayed in Chinese after login. I used
> Konqueror as the browser (Firefox is not installed by default under KDE
> LiveCD)to test the websites below:
>  http://www.sina.com.cn   Kind of slow due to the lack of Flash plugin, but all
> Chinese characters were correctly rendered.
>  http://www.google.cn     Perfectly displayed.
> 
> 
> From the reproduce steps I did above, I would like to say this could not be a
> problem about Fedora.
Comment 5 yd.nvstp 2009-02-20 02:31:01 EST
Sorry, I made a wrong description about the bug.

The correct steps to reproduce the bug:

1. open the "system settings"
2. open "appearance" setting module
3. select the "Fonts" setting
4. select "Enabled" in "Use anti-aliasing", then press "Configure..." button
5. select "RGB" in "Use sub-pixel rendering"
6. choose "Slight" in "Hinting style"
7. an last, press "Apply"

That all. Then we open the konqueror, open "www.google.cn", no Chinese fonts displayed!

I think this bug may be about the wenquanyi fonts.

(In reply to comment #3)
> Unfortunately, I am unable to reproduce this bug.
> 
> What I did is :
> 
> 1. Freshly install a Fedora 10 from Fedora-10-Live-KDE-i686
> 2. Upgrade KDE to 4.2 via su -c 'yum update kde*'
> 3. Because the default locale set of KDE LiveCD is en_US, I suppose the correct
> LANG environment variable is necessary: Changing the first line in
> /etc/sysconfig/i18n from LANG="en_US.UFT-8" to LANG="zh_CN.UTF-8" .
> 4. Install the KDE Language Pack via su -c 'yum install kde-l10n-Chinese'
> 5. Reboot the system.
> 
> Then the whole KDE interface was displayed in Chinese after login. I used
> Konqueror as the browser (Firefox is not installed by default under KDE
> LiveCD)to test the websites below:
>  http://www.sina.com.cn   Kind of slow due to the lack of Flash plugin, but all
> Chinese characters were correctly rendered.
>  http://www.google.cn     Perfectly displayed.
> 
> 
> From the reproduce steps I did above, I would like to say this could not be a
> problem about Fedora.
Comment 6 yd.nvstp 2009-02-20 02:32:35 EST
Created attachment 332681 [details]
steps to reproduce the bug

the picture is about the detail to reproduce this bug.
Comment 7 yd.nvstp 2009-02-20 02:49:45 EST
I find this bug may be about the wqy-bitmap-fonts-0.9.9-6.fc10.noarch package.
Because from the steps below, I can re-display the Chinese Fonts.

Method 1:
1. uninstall "wqy-bitmap-fonts-0.9.9-6.fc10.noarch"

Method 2:
1. un-selected "Use anti-aliasing" in Fonts setting module.


(In reply to comment #5)
> Sorry, I made a wrong description about the bug.
> 
> The correct steps to reproduce the bug:
> 
> 1. open the "system settings"
> 2. open "appearance" setting module
> 3. select the "Fonts" setting
> 4. select "Enabled" in "Use anti-aliasing", then press "Configure..." button
> 5. select "RGB" in "Use sub-pixel rendering"
> 6. choose "Slight" in "Hinting style"
> 7. an last, press "Apply"
> 
> That all. Then we open the konqueror, open "www.google.cn", no Chinese fonts
> displayed!
> 
> I think this bug may be about the wenquanyi fonts.
> 
> (In reply to comment #3)
> > Unfortunately, I am unable to reproduce this bug.
> > 
> > What I did is :
> > 
> > 1. Freshly install a Fedora 10 from Fedora-10-Live-KDE-i686
> > 2. Upgrade KDE to 4.2 via su -c 'yum update kde*'
> > 3. Because the default locale set of KDE LiveCD is en_US, I suppose the correct
> > LANG environment variable is necessary: Changing the first line in
> > /etc/sysconfig/i18n from LANG="en_US.UFT-8" to LANG="zh_CN.UTF-8" .
> > 4. Install the KDE Language Pack via su -c 'yum install kde-l10n-Chinese'
> > 5. Reboot the system.
> > 
> > Then the whole KDE interface was displayed in Chinese after login. I used
> > Konqueror as the browser (Firefox is not installed by default under KDE
> > LiveCD)to test the websites below:
> >  http://www.sina.com.cn   Kind of slow due to the lack of Flash plugin, but all
> > Chinese characters were correctly rendered.
> >  http://www.google.cn     Perfectly displayed.
> > 
> > 
> > From the reproduce steps I did above, I would like to say this could not be a
> > problem about Fedora.
Comment 8 yd.nvstp 2009-02-20 02:52:37 EST
Methhod 2 should be:

  un-selected "Use sub-pixel rendering" in "Use anti-aliasing" of Fonts setting module.

(In reply to comment #7)
> I find this bug may be about the wqy-bitmap-fonts-0.9.9-6.fc10.noarch package.
> Because from the steps below, I can re-display the Chinese Fonts.
> 
> Method 1:
> 1. uninstall "wqy-bitmap-fonts-0.9.9-6.fc10.noarch"
> 
> Method 2:
> 1. un-selected "Use anti-aliasing" in Fonts setting module.
> 
> 
> (In reply to comment #5)
> > Sorry, I made a wrong description about the bug.
> > 
> > The correct steps to reproduce the bug:
> > 
> > 1. open the "system settings"
> > 2. open "appearance" setting module
> > 3. select the "Fonts" setting
> > 4. select "Enabled" in "Use anti-aliasing", then press "Configure..." button
> > 5. select "RGB" in "Use sub-pixel rendering"
> > 6. choose "Slight" in "Hinting style"
> > 7. an last, press "Apply"
> > 
> > That all. Then we open the konqueror, open "www.google.cn", no Chinese fonts
> > displayed!
> > 
> > I think this bug may be about the wenquanyi fonts.
> > 
> > (In reply to comment #3)
> > > Unfortunately, I am unable to reproduce this bug.
> > > 
> > > What I did is :
> > > 
> > > 1. Freshly install a Fedora 10 from Fedora-10-Live-KDE-i686
> > > 2. Upgrade KDE to 4.2 via su -c 'yum update kde*'
> > > 3. Because the default locale set of KDE LiveCD is en_US, I suppose the correct
> > > LANG environment variable is necessary: Changing the first line in
> > > /etc/sysconfig/i18n from LANG="en_US.UFT-8" to LANG="zh_CN.UTF-8" .
> > > 4. Install the KDE Language Pack via su -c 'yum install kde-l10n-Chinese'
> > > 5. Reboot the system.
> > > 
> > > Then the whole KDE interface was displayed in Chinese after login. I used
> > > Konqueror as the browser (Firefox is not installed by default under KDE
> > > LiveCD)to test the websites below:
> > >  http://www.sina.com.cn   Kind of slow due to the lack of Flash plugin, but all
> > > Chinese characters were correctly rendered.
> > >  http://www.google.cn     Perfectly displayed.
> > > 
> > > 
> > > From the reproduce steps I did above, I would like to say this could not be a
> > > problem about Fedora.
Comment 9 Tommy He 2009-02-20 03:19:48 EST
wqy-bitmap-fonts is kind of obsolete according to the Wenquanyi Wiki

Personally, I recommend to use wqy-zenhei-fonts instead.
Comment 10 yd.nvstp 2009-02-20 04:49:53 EST
(In reply to comment #9)
> wqy-bitmap-fonts is kind of obsolete according to the Wenquanyi Wiki
> 
> Personally, I recommend to use wqy-zenhei-fonts instead.

Yes, I uninstalled wqy-bitmap-fonts and installed wqy-zenhei-fonts.
Everything is OK now.
Why does fedora not use wqy-zenhei-fonts to replace wqy-bitmap-fonts by default?
Comment 11 Tommy He 2009-02-20 20:52:57 EST
Well, wqy-bitmap-fonts is not the default for Chinese,either.

The default one is Sans.
Comment 12 Piotr Drąg 2009-06-13 00:01:16 EDT
Ping? Is it still a issue?
Comment 13 Piotr Drąg 2009-07-05 18:15:48 EDT
As there were no feedback in six months, I'm closing it as WONTFIX.
Comment 14 yd.nvstp 2009-07-05 23:39:58 EDT
(In reply to comment #13)
> As there were no feedback in six months, I'm closing it as WONTFIX.  

Sorry to not focus on this issue so long time.
I tried it again in KDE today. 
I installed package wqy-unibit-fonts-1.1.0-4.fc8.noarch while the package wqy-zenhei-fonts-0.8.38-1.fc10.noarch always exists all the time.

$ rpm -qa|grep wqy
wqy-unibit-fonts-1.1.0-4.fc8.noarch
wqy-zenhei-fonts-0.8.38-1.fc10.noarch

  But I cannot find WenQuanYi fonts in font list.

$ fc-list | grep Wen
文泉驿等宽正黑,文泉驛等寬正黑,WenQuanYi Zen Hei Mono:style=中等,Medium
文泉驿正黑,文泉驛正黑,WenQuanYi Zen Hei:style=中等,Medium

  And the font files already exist in font folder /usr/share/doc. And I have use fc-cache -fv to refresh font cache.

$ ls /usr/share/fonts/w*
/usr/share/fonts/wenquanyi-unibit:
fonts.dir  wqy-unibit.pcf

/usr/share/fonts/wqy-zenhei:
fonts.dir  wqy-zenhei.ttc
Comment 15 Yijun Yuan 2009-07-06 00:15:59 EDT
Anyone else to take it? I've no idea. Regarding #14 fc-cache is not intended to run by user right? And regarding subpixel rendering, maybe it is your monitor's RGB order problem? I don't know how to list font preference or precedence in one specific config.
Comment 16 Qianqian Fang 2009-07-06 00:33:12 EDT
(In reply to comment #14)
> (In reply to comment #13)
> > As there were no feedback in six months, I'm closing it as WONTFIX.  
> 
> Sorry to not focus on this issue so long time.
> I tried it again in KDE today. 
> I installed package wqy-unibit-fonts-1.1.0-4.fc8.noarch while the package
> wqy-zenhei-fonts-0.8.38-1.fc10.noarch always exists all the time.
> 

you did not mention if the problem still exist. If it does, please upload a screenshot for your bad Chinese rendering so that we can have a better understanding to your question.
Comment 17 yd.nvstp 2009-07-06 00:40:14 EDT
(In reply to comment #16)
> (In reply to comment #14)
> > (In reply to comment #13)
> > > As there were no feedback in six months, I'm closing it as WONTFIX.  
> > 
> > Sorry to not focus on this issue so long time.
> > I tried it again in KDE today. 
> > I installed package wqy-unibit-fonts-1.1.0-4.fc8.noarch while the package
> > wqy-zenhei-fonts-0.8.38-1.fc10.noarch always exists all the time.

I cannot use the WenQuanYi font now. Because of the problem, I cannot confirm whether this issue exits.
Comment 18 Qianqian Fang 2009-07-06 00:54:16 EDT
I am confused, you clearly mentioned you have two wqy fonts installed.

if you can not reproduce the problem, we can not fix it.
Comment 19 yd.nvstp 2009-07-06 01:01:44 EDT
These two fonts are all provided by wqy-zenhei-fonts-0.8.38-1.fc10.noarch. They are all "WenQuanYi Zen Hei" fonts.
Maybe this is a different new issue.
Comment 20 Qianqian Fang 2009-07-06 01:08:34 EDT
If I understand you correctly, your system works fine with WenQuanYi Zen Hei.

If you can not install wqy-bitmap-fonts and provide a screenshot for your previously reported issue, then I have to close this bug. Please let me know.
Comment 21 yd.nvstp 2009-07-06 01:22:20 EDT
I'm sorry for that. 
I uninstalled wqy-zenhei-fonts-0.8.38-1.fc10.noarch and reinstalled
wqy-unibit-fonts-1.1.0-4.fc8.noarch only again. But I cannot use wqy-unibit-fonts in
font list.

Yes, it works well with WenQuanYi ZenHei font.
I think WenQuanYi zenhei is very good. Using WenQuanYi as the default Chinese font may be a better selection.
I close this bug with WONTFIX. 
Thank you for your attention.

Note You need to log in before you can comment on or make changes to this bug.