Bug 486260 - Xorg hangs with 100% CPU usage when X starts
Xorg hangs with 100% CPU usage when X starts
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
i386 Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Triaged
Depends On:
  Show dependency treegraph
Reported: 2009-02-18 23:51 EST by Matt Hirsch
Modified: 2014-06-16 16:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-12-18 02:57:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Xorg server log (18.50 KB, text/plain)
2009-02-18 23:54 EST, Matt Hirsch
no flags Details
Backtraces (15.06 KB, text/plain)
2009-02-18 23:58 EST, Matt Hirsch
no flags Details
Minimal xorg.conf that causes the hangup. (970 bytes, text/plain)
2009-03-01 15:46 EST, Matt Hirsch
no flags Details
Xorg log file showing the system working at 1024x768 (85.28 KB, text/plain)
2009-03-01 15:49 EST, Matt Hirsch
no flags Details
This Xorg log file shows the crash with the minimal xorg.conf file (93.74 KB, text/plain)
2009-03-01 15:51 EST, Matt Hirsch
no flags Details

  None (edit)
Description Matt Hirsch 2009-02-18 23:51:52 EST
Description of problem:

I recently updated a system from Fedora 9 to Fedora 10. After the update, the Xorg server hangs with 100% CPU usage and the X desktop seems frozen. I can log into the system remotely. The system has an intel chip (more details below) and this may actually be an issue with the intel xorg driver.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Boot system (system starts X automatically)
Actual results:

Xorg hangs with 100% CPU usage

Expected results:

Normal X desktop experience

Additional info:

Here is the graphics chip in this system:

00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])
	Subsystem: IBM Device 0285
	Flags: fast devsel, IRQ 11
	Memory at f0000000 (32-bit, prefetchable) [size=128M]
	Memory at e0000000 (32-bit, non-prefetchable) [size=512K]
	I/O ports at 1800 [size=8]
	Capabilities: [d0] Power Management version 1
	Kernel modules: intelfb

I am attaching my xorg.conf file. I tried disabling DRI by adding Option      "DRI" "false", but the server crashes in the same way with or without the switch.

I have backtraces and the error log, which I will post below.
Comment 1 Matt Hirsch 2009-02-18 23:54:29 EST
Created attachment 332498 [details]
Xorg server log

Some strange things seem to be going on there...
Comment 2 Matt Hirsch 2009-02-18 23:58:10 EST
Created attachment 332499 [details]

After Xorg hangs, I installed the debuginfos for xorg-x11-server-Xorg and deps. I attached gdb and did some backtraces. It seems stuck in some infinite memory allocate/deallocate loop. But its difficult to debug, since after a few steps something issues a breakpoint signal. You can see this result in the last backtrace in that file.

If you need any further info to debug this please let me know.
Comment 3 Matt Hirsch 2009-02-19 00:05:11 EST
I tried renaming the xorg.conf file and I think this solved the problem. However, it still seems like a bug. The config file worked with previous versions of the X server. I'm setting priority to low.
Comment 4 Matt Hirsch 2009-03-01 15:45:58 EST
I'm changing the severity of this back to high, since it has the annoying side effect of preventing me from running at any resolution other than 1024x768.

I have tried updating to xorg-x11-server-Xorg-1.5.3-13.fc10.i386 and there is no change. There is a new intel xorg driver available, 2.6.0 (http://intellinuxgraphics.org/) but I can't compile it since the libdrm available from the repos is too old. Also, the release notes from the intel 2.6.0 driver say "i855 XV may cause hangs.  This was present in the previous release, and no workaround is known." I don't know if this is related to my problem - I have the i865 as shown above. Here's what I've tried in diagnosing the problem:

Found the minimal xorg.conf that creates the problem. See the xorg.conf attached below. This xorg.conf file causes Xorg to hang with 100% cpu usage. Commenting out the HorizSync and VertRefresh lines in the monitor section will allow Xorg to work. However, the system will be limited to running at 1024x768. If those lines are present, Xorg enumerates many more possible resolutions, and then the problem manifests. I have added the ModeDebug option to print additional debugging information in the log. Two additional logs are attached - one with the lines commented that shows the system working at 1024x768, and one with the lines uncommented that shows the system when it hangs. You can see in the latter case the system fails to allocate some buffers where it succeeded before. Based on the traces above this may be significant.

The symptoms remain the same when using EXA or XAA acceleration, and when disabling XVideo (see commented lines in xorg.conf).

I will try limiting the range of HorizSync and VertRefresh to see if there are specific resolutions that cause the problem.

There may be yet another bug in all of this. Once upon a time, the intel driver used to detect that the native resolution of the connected monitor is 1360x768. However, maybe a year ago it stopped auto-detecting this and I was forced to use the modeline you see present in the xorg.conf file. Without any xorg.conf file it only detects a resolution of 1024x768.

Please tell me what other information I can give you to help solve this. Can you recommend another place this bug report might be more appropriate? I would like to be as helpful as possible.
Comment 5 Matt Hirsch 2009-03-01 15:46:40 EST
Created attachment 333661 [details]
Minimal xorg.conf that causes the hangup.
Comment 6 Matt Hirsch 2009-03-01 15:49:33 EST
Created attachment 333662 [details]
Xorg log file showing the system working at 1024x768

This log file shows the system working with the minimal xorg.conf attached above with the HorizSync and VertRefresh lines commented.
Comment 7 Matt Hirsch 2009-03-01 15:51:00 EST
Created attachment 333663 [details]
This Xorg log file shows the crash with the minimal xorg.conf file

Note the failure to allocate some buffers in this log file, and the additional resolutions that were enabled.
Comment 8 Matt Hirsch 2009-03-01 16:00:49 EST
Adding Option "Tiling" "false" with the HorizSync and VertRefresh lines uncommented still causes a hangup. The buffer allocation still fails.
Comment 9 Matt Hirsch 2009-03-01 16:23:59 EST
When I set: 

    HorizSync       47.0 - 50.0
    VertRefresh     58.0 - 61.0

The server doesn't hang anymore, and I can use my custom modeline to get 1360x768. My guess is that the intel driver can't allocate enough memory for larger resolutions and does not fail gracefully.
Comment 10 seventhguardian 2009-10-15 03:45:46 EDT
Is this still true for Fedora 11? A lot has changed since then.
Comment 11 Bug Zapper 2009-11-18 04:52:00 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 12 Bug Zapper 2009-12-18 02:57:56 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 13 Matt Hirsch 2014-06-16 16:39:17 EDT
I'm commenting so this bug stops appearing in my outstanding requests list.

Note You need to log in before you can comment on or make changes to this bug.