Bug 486273 - Pressing Ctrl-Left sticks Ctrl key
Pressing Ctrl-Left sticks Ctrl key
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-19 01:35 EST by Matt Hirsch
Modified: 2018-04-11 07:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-18 18:23:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf file from affected system (2.68 KB, text/plain)
2009-02-19 21:44 EST, Matt Hirsch
no flags Details
Xorg log file from affected system (25.34 KB, text/plain)
2009-02-19 21:45 EST, Matt Hirsch
no flags Details

  None (edit)
Description Matt Hirsch 2009-02-19 01:35:09 EST
Description of problem:

If I press ctrl and the left arrow key, sometimes the system goes into a state where it seems as if the ctrl key is stuck down. Applications behave as if ctrl is pressed. However, the situation is not exactly identical to holding down the ctrl key. (I'll explain below).

I have only observed this problem when using gnome-terminal and emacs, and have not replicated it in another application yet.

Unplugging and reconnecting the keyboard has no effect. Pressing the ctrl key or others repeatedly has no effect. I have tried with two different USB keyboards of different brands (one apple, one from dell), which work fine on other systems.

I'm in the habit of pressing ctrl-left and right to skip between words in text, so this is very annoying. When it happens, the only recourse is to press ctrl-alt-backspace to restart the X server.

It may have begun near the time when the system switched to using evdev to manage the keyboard.

Version-Release number of selected component (if applicable):

kernel-2.6.27.12-170.2.5.fc10.x86_64
xorg-x11-server-Xorg-1.5.3-6.fc10.x86_64
xorg-x11-drv-evdev-2.1.1-1.fc10.x86_64
metacity-2.24.0-2.fc10.x86_64
compiz-0.7.9-4.fc10.x86_64

How reproducible:
Possible to reproduce in 30 seconds or less, though it does not happen every time the key combination is pressed.

Steps to Reproduce:
1. Open gnome-terminal
2. Press ctrl key and left arrow key. It does not matter which ctrl key is pressed.
3. Release and repeat until key gets stuck.
  
Actual results:

Ctrl key seems to get stuck.

Expected results:

Normal keyboard operation

Additional info:

I am running compiz. I haven't tried this without compiz. However, I can log in remotely and kill compiz, and then restart it, and the key seems to remain stuck. So I think its some other component causing the problem.

For the most part the symptoms can be simulated by holding down one of the ctrl keys on the keyboard and trying to use the system. Menus only highlight but will not drop down. Text can be selected but nothing can be typed. Clicking on a window without the focus raises that window to the focus (the title bar changes color). Icons can be clicked but not double-clicked. However, there is one critical difference. If I open xev, holding the ctrl key and pressing another key produces some output. If I click on xev after this error has occurred xev does not get any input when keys are pressed. Somehow the ctrl-alt-backspace shortcut does still work.

I don't see any abnormal messages in the Xorg log or /var/log/messages.
Comment 1 Matt Hirsch 2009-02-19 01:41:20 EST
One amendment: It does not ALWAYS seem possible to reproduce the error quickly. I was attempting to reproduce it again to continue testing and at the moment I am not able to.
Comment 2 Matt Hirsch 2009-02-19 02:09:01 EST
This bug seems related to key repeat. Holding down ctrl and the left arrow key until the key repeats seems to increase the chances of triggering the bug. Also, pressing ctrl right and then ctrl left increases the odds. In fact, it may be necessary to press ctrl right and ctrl left to trigger the bug. The hangup always seems to occur when the left arrow is pressed, but without ever pressing the right arrow I have not been able to cause it.
Comment 3 Matěj Cepl 2009-02-19 11:02:58 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 4 Matt Hirsch 2009-02-19 21:44:13 EST
Created attachment 332661 [details]
xorg.conf file from affected system
Comment 5 Matt Hirsch 2009-02-19 21:45:11 EST
Created attachment 332662 [details]
Xorg log file from affected system

This is the log file from the system before any problems occur. No additional messages appear after the problem occurs.
Comment 6 Bug Zapper 2009-11-18 06:09:34 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Matt Hirsch 2009-11-18 17:14:42 EST
This does not affect current F11 Xorg.
Comment 8 Peter Hutterer 2009-11-18 18:23:22 EST
Closing per comment #7.

Note You need to log in before you can comment on or make changes to this bug.