Bug 486275 - menu pollution
menu pollution
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-19 01:37 EST by Matthias Clasen
Modified: 2009-02-25 01:47 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-25 01:47:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2009-02-19 01:37:05 EST
What is the plan, going forward, wrt to im-chooser ? I'd hate to have
2 input method related menuitems in the default install. My preference
would be to not install the im-chooser by default, since it is only
needed to switch back to 'legacy' frameworks.

It would be great if we could use the generic "Input Method" menuitem
for the ibus preferences, and maybe rename im-chooser to "Input Method
Framework" or something like that.

Alternatively, if we can't get rid of im-chooser by default, maybe
ibus-setup should not have its own menu item (I notice that scim-setup
doesn't have one either), since it is available via im-chooser.


Another case of 'menu pollution' that I only spotted after doing the
review is that IBus puts another menu item at Applications ->
Accessories -> IBus. That is not good, imo. First of all, the menu label
does not explain at all what it does, and second, it just duplicates the
functionality for starting an im framework that is already present with
im-chooser. Such duplication is just confusing, please drop it.
Comment 1 Peng Huang 2009-02-23 02:15:30 EST
Hide two ibus icons.
Comment 2 Peng Huang 2009-02-25 01:47:47 EST
The new release has been built

Note You need to log in before you can comment on or make changes to this bug.