This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 4863 - The sendmail.cf that comes with RH6.0 causes sendmail -bt to report that *EVERYTHING* is delivered via the local mailer
The sendmail.cf that comes with RH6.0 causes sendmail -bt to report that *EVE...
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: sendmail (Show other bugs)
6.0
All Linux
low Severity low
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-09-02 15:28 EDT by tpavlic
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-05 02:21:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tpavlic 1999-09-02 15:28:00 EDT
sendmail on RH6.0 seems to work fine sending mail, but when
one uses sendmail -bt to test an address:

0 tpavlic@netwalk.com
0 tpavlic
0 bob@something.com.UUCP
0 anything@anything

sendmail reports that the mail is delivered locally. This
should not be the case, and cannot be the case as mail is
actually going through. (SMTP mail, that is) I'm trying to
be sure that certain customers of mine who use UUCP will
have their mail routed correctly through sendmail, but
sendmail -bt reports that everything is routed locally,
which makes things very hard to debug. :)
Comment 1 tpavlic 1999-09-02 16:52:59 EDT
I've always used 0 to parse addresses when debugging sendmail.
Someone recently informed me of the /parse routine in sendmail -bt. I
tried /parse and things worked fine.
Comment 2 Cristian Gafton 1999-10-05 02:21:59 EDT
I always thought that ruleset 3 was the one that was handling the
actual resolving to what mailer should be used for a particular
address, and ruleset 0 was only processing the final step of delivery.

Anyway, things now seem to work fin, bug closed.

Note You need to log in before you can comment on or make changes to this bug.