Bug 486308 - HVM guest stops running when xm save fails
HVM guest stops running when xm save fails
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: 5.6
Assigned To: Michal Novotny
Virtualization Bugs
:
Depends On:
Blocks: 514500
  Show dependency treegraph
 
Reported: 2009-02-19 05:37 EST by Jiri Denemark
Modified: 2014-02-02 17:36 EST (History)
6 users (show)

See Also:
Fixed In Version: xen-3.0.3-109.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-13 17:16:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xend.log (1.88 KB, text/plain)
2009-02-19 05:37 EST, Jiri Denemark
no flags Details
qemu-dm.10617.log (659 bytes, text/plain)
2009-02-19 05:38 EST, Jiri Denemark
no flags Details
Recreate device model when HVM save fails (4.29 KB, patch)
2010-04-02 12:36 EDT, Michal Novotny
no flags Details | Diff
New version of device model recreation patch (3.29 KB, patch)
2010-04-12 08:01 EDT, Michal Novotny
no flags Details | Diff

  None (edit)
Description Jiri Denemark 2009-02-19 05:37:38 EST
Created attachment 332523 [details]
xend.log

Description of problem:

When xm save of an HVM guest fails, the guest stops running.

Version-Release number of selected component (if applicable):

xen-3.0.3-80.el5, xen-3.0.3-64.el5

How reproducible:

always

Steps to Reproduce:
1. create an HVM guest
2. xm save guest /mnt/small/guest.save
  
Actual results:

The guest stops running, xm list shows no status:

fv-rhel5-64  4  511   2 ------  45.3

Expected results:

The guest should remain running as if no xm save command was ever issued

Additional info:

No qemu-dm is running in dom0 after failed xm save
Comment 1 Jiri Denemark 2009-02-19 05:38:23 EST
Created attachment 332524 [details]
qemu-dm.10617.log
Comment 2 Michal Novotny 2009-04-07 09:32:10 EDT
Well, I have tried this on 83-jd2 with my patches (available at http://people.redhat.com/minovotn/xen ) and I was unable to replicate it using this scenario:

1. xm create -c FVguest
2. wait to login
3. make domain working using eg. `find /` in domain console (or ssh)
4. do `xm save FVguest /mnt/small/guest.save` -> error
5. `xm list` still shows domain
6. attach to console for domain, console is working and listing files
7. terminate console and shutdown the guest, system starts shutting down

Michal
Comment 3 Jiri Denemark 2009-04-08 04:14:53 EDT
I probably should have made it more clear... xm save guest /mnt/small/guest.save is supposed to fail because of insufficient space on the drive mounted to /mnt/small and not because the path does not exist at all.
Comment 4 Michal Novotny 2009-05-13 04:12:27 EDT
Ok, thanks for clarification :) It's good to know that ;)
Comment 6 Michal Novotny 2010-04-02 12:36:05 EDT
Created attachment 404212 [details]
Recreate device model when HVM save fails

This is the patch to recreate device model when xm save on HVM domains fails, also device reinitialization had to be added since otherwise the guest network was not working.

Michal
Comment 9 Michal Novotny 2010-04-12 08:01:10 EDT
Created attachment 405944 [details]
New version of device model recreation patch

This is the new version of my patch to recreate device model when HVM guest save fails with the reconnection logic moved to DevController class.

Michal
Comment 13 Linqing Lu 2010-08-25 05:29:38 EDT
This bug has been verified in xen-3.0.3-115.el5
The PV guest runs WELL after "xm save" failed.
Comment 15 errata-xmlrpc 2011-01-13 17:16:28 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0031.html

Note You need to log in before you can comment on or make changes to this bug.