Bug 486373 - anaconda does not remove /etc/init.d/livesys* and /etc/rc*.d/*livesys*
anaconda does not remove /etc/init.d/livesys* and /etc/rc*.d/*livesys*
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-19 10:02 EST by Corentin Perard-Gayot
Modified: 2009-03-17 14:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-17 14:48:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corentin Perard-Gayot 2009-02-19 10:02:05 EST
Description of problem:
when performing fedora installation from a live-cd, anaconda does not remove livesys* services

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.launch a fedora live-cd
2.run install by double-clicking icon on the desktop
3.reboot when install is finished
  
Actual results:
livesys and livesys-late services are still there, and enabled (even if they automatically detect we're not running fedora from a live cd)

Expected results:
no more livesys and livesys-late services

Additional info:
the commands I performed to remove the services are :
chkconfig --del livesys
chkconfig --del livesys-late
rm /etc/init.d/livesys /etc/init.d/livesys-late

I believe it should be easy to add this in anaconda post-install script, but there is maybe something that prevents it and that i am not aware of...

I have not tested anaconda's behavior with the F11a release, maybe this issue also exists with this release...
Comment 1 Corentin Perard-Gayot 2009-03-16 09:26:22 EDT
ping ? what about F11 ?
Comment 2 Jeremy Katz 2009-03-17 14:48:06 EDT
The problem is there's no generic way for anaconda to know this.  The livesys initscripts are put in by each live image's kickstart config and there is nothing to tell anaconda what exists and would want to have this done in a generic fashion.  And hardcoding means that it won't work for customizers

The initscripts immediately exit as soon as they run, so having them isn't a problem.

Note You need to log in before you can comment on or make changes to this bug.