Bug 486409 - Wrong python binding installed path
Summary: Wrong python binding installed path
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: libchewing   
(Show other bugs)
Version: 9
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Ding-Yi Chen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-02-19 16:56 UTC by Chien-Chung Yeh
Modified: 2009-03-25 16:13 UTC (History)
2 users (show)

Fixed In Version: 0.3.2-6.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-25 16:05:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chien-Chung Yeh 2009-02-19 16:56:44 UTC
Description of problem:
Python binding files placed in wrong directory "/libchewing/".

Version-Release number of selected component (if applicable):
libchewing-0.3.2-4.fc9

How reproducible:
Always

Steps to Reproduce:
1. rpm -ql libchewing-0.3.2-4.fc9.i386
2.
3.
  
Actual results:
/libchewing
/libchewing/__init__.py
/libchewing/chewing.py
/usr/lib/chewing
/usr/lib/chewing/fonetree.dat
...

Expected results:
/usr/lib/python2.5/site-packages/libchewing
/usr/lib/python2.5/site-packages/libchewing/__init__.py
/usr/lib/python2.5/site-packages/libchewing/chewing.py
/usr/lib/chewing
/usr/lib/chewing/fonetree.dat
...

Additional info:
Refer to Koji's build.log, the following lines show where the problem is:

ENTER do(['bash', '--login', '-c', 'rpmbuild -bs --target i386 --nodeps builddir/build/SPECS/libchewing.spec'], False, '/var/lib/mock/dist-f9-build-333781-61391/root/', None, 86400, True, 0, 102, 103, None, logger=<mock.trace_decorator.getLog object at 0x2ba91b8faf10>)
Executing command: ['bash', '--login', '-c', 'rpmbuild -bs --target i386 --nodeps builddir/build/SPECS/libchewing.spec']
sh: /usr/bin/python: No such file or directory
sh: /usr/bin/python: No such file or directory
sh: /usr/bin/python: No such file or directory
sh: /usr/bin/python: No such file or directory

Suggest add following line in "libchewing.spec" to avoid this problem:
BuildRequires: python-devel

Comment 1 Ding-Yi Chen 2009-02-20 07:12:46 UTC
Issue fixed, the revision build will be in koji and bodhi shortly.

Comment 2 Fedora Update System 2009-02-24 20:48:01 UTC
libchewing-0.3.2-6.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libchewing'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-1970

Comment 3 Fedora Update System 2009-02-24 20:56:04 UTC
libchewing-0.3.2-6.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update libchewing'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-2021

Comment 4 Chien-Chung Yeh 2009-03-01 14:56:48 UTC
I test it, this update(repo=updates-testing-newkey) works in FC9. But I do not own FC10, so leave FC10's test for somebody else.

By the way, I provide feedback by "http://admin.fedoraproject.org/updates/F9/FEDORA-2009-2021" on 2009-02-26. This update still not pushed to "RELEASE_PENDING" yet. So I think it's better to provide feedback here too.

Comment 5 Chien-Chung Yeh 2009-03-12 17:35:46 UTC
I upgrade my system from Fedora 9 to Fedora 10 today, package "libchewing-0.3.2-4.fc10.i386" do not have this issue. The bug only exist in FC9.

Comment 6 Fedora Update System 2009-03-25 16:05:46 UTC
libchewing-0.3.2-6.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2009-03-25 16:13:08 UTC
libchewing-0.3.2-6.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.