Bug 486417 - [RFE]: Make readahead smarter
[RFE]: Make readahead smarter
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: readahead (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-19 12:20 EST by David Kovalsky
Modified: 2014-03-31 19:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-13 07:47:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to ignore large files (2.53 KB, patch)
2009-09-26 16:13 EDT, Raphael Geissert
no flags Details | Diff

  None (edit)
Description David Kovalsky 2009-02-19 12:20:40 EST
* Refuse to run readahead on a memory starved system (<512MB)
* Run with low priority (ionice)
* Don't preload database files, which make things slower
  (Full read vs. application seek)
For exaple kmods which read RPM database
Comment 1 Harald Hoyer 2009-02-19 12:23:50 EST
move datafiles to /var
Comment 2 Harald Hoyer 2009-02-20 04:50:00 EST
readahead-1.4.8 with ionice, more excluded directories and does not run on memory < 384MB
Comment 3 Raphael Geissert 2009-09-26 16:13:48 EDT
Created attachment 362779 [details]
patch to ignore large files

(In reply to comment #2)
> readahead-1.4.8 with ionice, more excluded directories and does not run on
> memory < 384MB  

Please excuse me for replying to this old report, but why do you think that not running readahead when the machine doesn't have more than 348MBs is "helpful"?
At the Debian package I've reverted that change since it doesn't make sense to me, as the amount of memory required to preload the files is directly dependent on what the system loads and on what the user can actually have running at the same time. On several setups, even when not excluding /var I get ~60 when running
cat /var/lib/readahead/early.sorted | awk '{sum+=$1/1024/1024}END{print sum}'

If I were to place a minimum memory requirement I would say users should at least have 128MB of memory.

In any case, I'm attaching a patch I applied to ignore large files (in part so that there's no need to exclude /var).
Comment 4 Harald Hoyer 2009-10-06 10:23:56 EDT
pushed to upstream git

Note You need to log in before you can comment on or make changes to this bug.