Bug 486422 - GSSAPI auth still displays a password dialog
GSSAPI auth still displays a password dialog
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: claws-mail (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-19 12:33 EST by Jon Orris
Modified: 2009-06-30 09:14 EDT (History)
3 users (show)

See Also:
Fixed In Version: 3.7.1-2.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-26 23:01:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch that should fix it (1.14 KB, patch)
2009-03-27 18:13 EDT, Colin Leroy
no flags Details | Diff

  None (edit)
Description Jon Orris 2009-02-19 12:33:43 EST
Description of problem:
When using GSSAPI authentication with Kerberos, a password dialog is still displayed. claws will not continue fetching mail until something is entered. Note that an actual password is not required. A random character or two is all that is needed to dismiss the dialog and have Claws use gssapi to authenticate.

Version-Release number of selected component (if applicable):
claws-mail-3.7.0-1.fc10.x86_64

How reproducible:
Always 

Steps to Reproduce:
1. Set Authentication Method to GSSAPI for a mail server that supports it.
2. kinit
3. Click on Inbox or Get Mail
  
Actual results:
The password dialog box appears, and refuses to authenticate until a random string is entered.

Expected results:
No password dialog, Claws goes ahead with GSSAPI authentication uninterrupted.

Additional info:
Comment 1 Colin Leroy 2009-03-27 18:13:24 EDT
Created attachment 337072 [details]
Patch that should fix it

We fixed it once, but reverted the patch because of testing and it was too near a release. We since forgot to reapply it.

Could you test the attached patch (which should apply fine) and tell me whether it works fine?

I wouldn't want to apply it without testing.

Thanks in advance!
Comment 2 Jon Orris 2009-03-30 12:41:07 EDT
Yes, this patch works just fine.

Thanks!
Comment 3 Jeff Layton 2009-06-01 07:49:52 EDT
Moving this back to ASSIGNED. The patch doesn't seem to be in yet (at least not in rawhide). Any idea when this will make it into a release? Below is a snippet of the network log:

----------------[snip]----------------
[07:45:21] IMAP4< * OK IMAP4 ready 
* IMAP connection is un-authenticated   <<<< (password dialog pops up here)
[07:45:27] IMAP4> 1 CAPABILITY 
[07:45:27] IMAP4< * CAPABILITY ACL BINARY CATENATE CHILDREN CONDSTORE ENABLE ESEARCH ID IDLE IMAP4rev1 LIST-EXTENDED LITERAL+ MULTIAPPEND NAMESPACE QRESYNC QUOTA RIGHTS=ektx SASL-IR SEARCHRES UIDPLUS UNSELECT WITHIN AUTH=PLAIN AUTH=GSSAPI 
[07:45:27] IMAP4< 1 OK completed 
[07:45:27] IMAP4> Logging jlayton to mail.foo.bar using GSSAPI
[07:45:27] IMAP4< completed
** IMAP error on mail.foo.bar: LOGIN error
[07:45:27] IMAP4< Error logging in to mail.foo.bar
[07:45:34] IMAP4< * BYE Zimbra IMAP server terminating connection 
[07:45:34] IMAP4< 2 OK completed 
----------------[snip]----------------

I'm also having problems authenticating at all with GSSAPI, but that seems to be a separate issue.
Comment 4 Andreas Bierfert 2009-06-01 15:46:08 EDT
Will take care of it asap.
Comment 5 Fedora Update System 2009-06-17 09:40:21 EDT
claws-mail-3.7.1-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/claws-mail-3.7.1-2.fc10
Comment 6 Fedora Update System 2009-06-17 09:40:57 EDT
claws-mail-3.7.1-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/claws-mail-3.7.1-2.fc11
Comment 7 Fedora Update System 2009-06-19 09:39:10 EDT
claws-mail-3.7.1-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update claws-mail'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-6722
Comment 8 Fedora Update System 2009-06-26 22:57:18 EDT
claws-mail-3.7.1-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2009-06-26 23:01:35 EDT
claws-mail-3.7.1-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Jon Orris 2009-06-30 09:14:14 EDT
Verified on F10 x86_64

Note You need to log in before you can comment on or make changes to this bug.