Bug 486424 - ISE When Editing Kickstart Partition Layout
ISE When Editing Kickstart Partition Layout
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
0.4
All Linux
low Severity medium
: ---
: ---
Assigned To: Justin Sherrill
Devan Goodwin
:
Depends On:
Blocks: space06
  Show dependency treegraph
 
Reported: 2009-02-19 12:41 EST by Devan Goodwin
Modified: 2009-09-10 08:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 08:05:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Devan Goodwin 2009-02-19 12:41:39 EST
Description of problem:

ISE generated when submitting changes to a kickstart profile's partition layout.

Version-Release number of selected component (if applicable):

Spacewalk 0.4.

How reproducible:

Unsure.

Steps to Reproduce:
1. Create a kickstart profile.
2. Navigate to the new profile, System Details, Partitioning
3. Make a change and submit.
  
Actual results:

Caused by: com.redhat.rhn.common.hibernate.HibernateRuntimeException: HibernateException executing CachedStatement
        at com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:463)
        at com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:425)
        at com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:329)
        at com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:334)
        at com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:274)
        at com.redhat.rhn.common.db.datasource.SelectMode.execute(SelectMode.java:105)
        at com.redhat.rhn.manager.channel.ChannelManager.getLatestPackageEqual(ChannelManager.java:1232)
        at com.redhat.rhn.manager.kickstart.KickstartFormatter.getUpdatePackages(KickstartFormatter.java:769)
        at com.redhat.rhn.manager.kickstart.KickstartFormatter.getRhnPost(KickstartFormatter.java:533)
        at com.redhat.rhn.manager.kickstart.KickstartFormatter.getFileData(KickstartFormatter.java:201)
        at com.redhat.rhn.domain.kickstart.KickstartFactory.saveKickstartData(KickstartFactory.java:337)
        at com.redhat.rhn.domain.kickstart.KickstartFactory.saveKickstartData(KickstartFactory.java:387)
        at com.redhat.rhn.manager.kickstart.BaseKickstartCommand.store(BaseKickstartCommand.java:85)
        at com.redhat.rhn.frontend.action.kickstart.BaseKickstartEditAction.execute(BaseKickstartEditAction.java:87)
        at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:431)
        ... 40 more
Caused by: org.hibernate.ObjectDeletedException: deleted object would be re-saved by cascade (remove deleted object from associations): [com.redhat.rhn.domain.kickstart.KickstartCommand#750]
        at org.hibernate.impl.SessionImpl.forceFlush(SessionImpl.java:1014)
        at org.hibernate.event.def.DefaultSaveOrUpdateEventListener.entityIsTransient(DefaultSaveOrUpdateEventListener.java:165)
        at org.hibernate.event.def.DefaultSaveOrUpdateEventListener.performSaveOrUpdate(DefaultSaveOrUpdateEventListener.java:94)
        at org.hibernate.event.def.DefaultSaveOrUpdateEventListener.onSaveOrUpdate(DefaultSaveOrUpdateEventListener.java:70)
        at org.hibernate.impl.SessionImpl.fireSaveOrUpdate(SessionImpl.java:507)
        at org.hibernate.impl.SessionImpl.saveOrUpdate(SessionImpl.java:499)
        at org.hibernate.engine.CascadingAction$5.cascade(CascadingAction.java:218)
        at org.hibernate.engine.Cascade.cascadeToOne(Cascade.java:268)
        at org.hibernate.engine.Cascade.cascadeAssociation(Cascade.java:216)
        at org.hibernate.engine.Cascade.cascadeProperty(Cascade.java:169)
        at org.hibernate.engine.Cascade.cascadeCollectionElements(Cascade.java:296)
        at org.hibernate.engine.Cascade.cascadeCollection(Cascade.java:242)
        at org.hibernate.engine.Cascade.cascadeAssociation(Cascade.java:219)
        at org.hibernate.engine.Cascade.cascadeProperty(Cascade.java:169)
        at org.hibernate.engine.Cascade.cascade(Cascade.java:130)
        at org.hibernate.event.def.AbstractFlushingEventListener.cascadeOnFlush(AbstractFlushingEventListener.java:131)
        at org.hibernate.event.def.AbstractFlushingEventListener.prepareEntityFlushes(AbstractFlushingEventListener.java:122)
        at org.hibernate.event.def.AbstractFlushingEventListener.flushEverythingToExecutions(AbstractFlushingEventListener.java:65)
        at org.hibernate.event.def.DefaultFlushEventListener.onFlush(DefaultFlushEventListener.java:26)
        at org.hibernate.impl.SessionImpl.flush(SessionImpl.java:1000)
        at com.redhat.rhn.common.db.datasource.CachedStatement.stealConnection(CachedStatement.java:847)
        at com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:435)
        ... 54 more


Additional info:
Comment 1 Justin Sherrill 2009-07-31 12:19:02 EDT
This seems to be fixed with some other cobbler changes we made.
Comment 2 Miroslav Suchý 2009-09-10 08:05:28 EDT
Spacewalk 0.6 released

Note You need to log in before you can comment on or make changes to this bug.