Bug 486436 - inserting SD card causes error on a XO
inserting SD card causes error on a XO
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FedoraOnXO
  Show dependency treegraph
 
Reported: 2009-02-19 13:35 EST by Jerry Vonau
Modified: 2009-03-25 00:33 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-25 00:33:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full /var/log/messages (12.96 KB, application/x-gzip)
2009-02-19 13:35 EST, Jerry Vonau
no flags Details

  None (edit)
Description Jerry Vonau 2009-02-19 13:35:26 EST
Created attachment 332608 [details]
full /var/log/messages

Description of problem:
On a freshly booted, from a usbkey, 20090218 image from: 
http://dev.laptop.org/~cjb/rawhide-xo/

when I inserted a CF card, the following is recorded in /var/log/messages:

  Feb 19 16:07:48 localhost kernel: mmc0: new high speed SDHC card at
address 2f2f
Feb 19 16:07:49 localhost kernel: mmcblk0: mmc0:2f2f SD04G 3.69 GiB 
Feb 19 16:07:59 localhost kernel: mmcblk0:<3>mmc0: Timeout waiting for
hardware interrupt.
Feb 19 16:07:59 localhost kernel: mmcblk0: retrying using single block
read
Feb 19 16:07:59 localhost kernel: p1 p2
Feb 19 16:08:01 localhost pulseaudio[2388]: module-hal-detect.c: D-Bus
error while parsing HAL data: org.freedesktop.Hal.NoSuchProperty: No
property info.capabilities on device with
id /org/freedesktop/Hal/devices/pci_11ab_4101_mmc_host_mmc_card_rca12079
Feb 19 16:08:10 localhost kernel: mmc0: Timeout waiting for hardware
interrupt.
Feb 19 16:08:10 localhost kernel: mmcblk0: retrying using single block
read

Version-Release number of selected component (if applicable):
20090218 image

How reproducible:
boot the live image on a XO

Steps to Reproduce:
1.boot the above live image on a XO
2.insert CF card
3.
  
Actual results:
fails with above message

Expected results:
mounted CF card.

Additional info:
Comment 1 Chuck Ebbert 2009-02-21 01:01:10 EST
Looks like the fix for this is in the works:

http://marc.info/?l=linux-kernel&m=123518542131291&w=2
Comment 2 Chuck Ebbert 2009-03-03 11:28:50 EST
Should be fixed in -rc6-git7. Please test when that becomes available.
Comment 3 Chuck Ebbert 2009-03-25 00:33:22 EDT
Assuming this is fixed.

Note You need to log in before you can comment on or make changes to this bug.