Bug 486449 - rhythmbox-upnp does not work with PS3 (probably related to no sample reate info)
rhythmbox-upnp does not work with PS3 (probably related to no sample reate info)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-19 15:04 EST by Andreas Tunek
Modified: 2009-02-22 03:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-22 03:53:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Photo of PS3 trying to play mp3 (1.21 MB, image/png)
2009-02-19 15:04 EST, Andreas Tunek
no flags Details

  None (edit)
Description Andreas Tunek 2009-02-19 15:04:39 EST
Created attachment 332630 [details]
Photo of PS3 trying to play mp3

Description of problem:
If you connect a PS3 to rhythmbox using the upnp plugin the PS3 can see the songs but can't play the songs. I guess this is because rhythmbox does not send any sample rate info about the songs (see attached photo).

Version-Release number of selected component (if applicable):
rhythmbox-upnp.i586 0:0.11.6-25.r6096.fc11 
rhythmbox.i586 0:0.11.6-25.r6096.fc11

How reproducible:
Always

Steps to Reproduce:
1. Enable upnp in rhythmbox
2. Try to play a mp3 on the PS3
  
Actual results:
PS3 reports file unsupported.

Expected results:
PS3 should play file.

Additional info:
See attached photo
Comment 1 Bastien Nocera 2009-02-19 15:30:37 EST
Unlikely. Any errors on the console from the Rhythmbox side? Do you see any DLNA errors on the PS3?

My guess is that it's broken in Coherence...
Comment 2 Andreas Tunek 2009-02-22 03:52:43 EST
Actually, I was wrong. The PS3 can play files stored locally on your computer, but not files accessed through GIO/GnomeVFS. Will file new bug about that problem.

Note You need to log in before you can comment on or make changes to this bug.