Bug 486459 - expresskeys needs to tell linuxwacom to not handle the scrollwheel when it is in charge of it [NEEDINFO]
expresskeys needs to tell linuxwacom to not handle the scrollwheel when it is...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: wacomexpresskeys (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Aristeu Rozanski
desktop-bugs@redhat.com
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-19 16:00 EST by Suzanne Hillman
Modified: 2014-06-02 09:23 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:23:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (shillman)


Attachments (Terms of Use)
test patch (2.80 KB, patch)
2009-02-24 13:47 EST, Aristeu Rozanski
no flags Details | Diff

  None (edit)
Description Suzanne Hillman 2009-02-19 16:00:24 EST
Description of problem:
expresskeys needs to tell linuxwacom to not handle the scrollwheel when it is in charge of it.

On the graphire4 (and likely others), the scroll wheel is working without expresskeys running, and if you set the scroll wheel to other keys than scrolling, both scrolling and those keys will happen.

"xsetwacom get pad-4x5 RelWUp" returns "5", which apparently means it's not clearing a setting it should be setting.

Version-Release number of selected component (if applicable):
wacomexpresskeys-0.4.1-12.el4

How reproducible:
Always

Steps to Reproduce:
1. Edit the .expresskeys/[tabletname].conf1 file to change the behavior of the scroll wheel.
2. Use the scroll wheel
  
Actual results:
Both scrolling and the behavior set for expresskeys happens.

Expected results:
Just the expresskeys behavior should happen.

Additional info:
Not a regression.
Comment 2 Aristeu Rozanski 2009-02-24 13:47:17 EST
Created attachment 333076 [details]
test patch

backport of an upstream patch to fix the issue.
not tested yet.
Comment 5 RHEL Product and Program Management 2009-11-06 13:47:30 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 8 RHEL Product and Program Management 2014-03-07 08:55:20 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 9 RHEL Product and Program Management 2014-06-02 09:23:01 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.