Bug 486478 - Size of pager on widget dashboard changes
Size of pager on widget dashboard changes
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-19 17:33 EST by antserg
Modified: 2009-05-26 09:57 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-26 09:57:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
image of the pager (14.73 KB, image/png)
2009-02-19 17:33 EST, antserg
no flags Details

  None (edit)
Description antserg 2009-02-19 17:33:16 EST
Created attachment 332646 [details]
image of the pager

Description of problem:
A pager put directly on the dashboard, not in a panel, has size problems:
1. it shrinks at any login (regardless widgets are locked or not)
2. the shades that highlight desktops inside pager are larger than needed

Version-Release number of selected component (if applicable):
kdebase-workspace-4.2.0-8.fc9.i386

How reproducible:
Always

Steps to Reproduce:
1. Add a pager on dashboard (not in a panel) (in fresh .kde or not should not matter)
2. Make it 4 rows (16 virtual desktops)
3. Choose Oxygen as theme
4. Resize it (about 1/3 of the side of the screen) and position it
5. Logout (session manager on "Restore previous session")
6. Login and logout several times without touching anything
  
Actual results:
The pager progressively shrinks and shades are always out of boundaries

Expected results:


Additional info:
Changing several themes and going back to Oxygen and then resizing makes the pager correctly calculate the shades size, but at next logout-login the problem is always there.
It started after the latest update (to kde 4.2.0)
Comment 1 antserg 2009-02-27 01:43:26 EST
I upgraded to fedora 10 (for other reasons) and to kdebase-workspace-4.2.0-8.fc10.i386 with the same result: the pager shrinks progressively at each login.
Comment 2 Rex Dieter 2009-03-11 12:18:13 EDT
I'd suggest reporting this upstream to the kde project @ bugs.kde.org.  They're the ones best equipped to address this.

In the meantime, I'll see if I can reproduce this.
Comment 3 Rex Dieter 2009-03-11 12:27:42 EDT
Using kde-4.2.1 (currently in updates-testing) on my f10/x86_64 laptop (intel945 graphics), and I cannot reproduce.
Comment 4 antserg 2009-03-12 04:15:23 EDT
I tried to upgrade to kde-4.2.1 to see if the problem was still there; it is.
To test it I minimized the steps:
from a fresh configuration, remove pager from panel, add it to dashboard, put it below the default folder view (Desktop), lock widgets, logout and login.

About the hardware configuration etc:
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 04)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 04)

2.6.27.19-170.2.35.fc10.i686 #1 SMP Mon Feb 23 13:21:22 EST 2009 i686 i686 i386 GNU/Linux

But I'm experiencing the same problem since upgraded to kde-4.2, with the same OS installation (USB disk), on another laptop which uses openchrome driver.

It sounds like it has something to do with this new "self alignment" feature for dashboard widgets; I get also weird behaviour during pager widget resize, like sometimes jumping in another position or resizing in opposite direction.

Another information I can give is that with kde-4.2.0 in fc9 (my previous installation) the kde splash screen wasn't in the center of the screen anymore; probably something has changed in the way the screen size is calculated by kde.
Comment 5 antserg 2009-03-15 02:59:44 EDT
Funny ... 3 days after the last upgrade the problem suddenly disappeared; maybe a prelink effect. Anyhow I cannot reproduce it anymore.
Comment 6 Steven M. Parrish 2009-03-16 21:56:37 EDT
Since the issue has been resolved for the moment will close this, if it happens again feel free to reopen
Comment 7 antserg 2009-04-26 04:12:28 EDT
It happens again; 2 days after the upgrade to 4.2.2-3.fc10.i386, but actually this time it started after a system hang. I tried to remove any temporary file (in /tmp and /var/tmp) that could be related.
Is it possible it is due to a bad cache/tmp file that is updated once in a while?
I tried to figure out where to find any further kde related cache/tmp file, but I found nothing more than /tmp and /var/tmp.

Any suggestion?
Comment 8 Steven M. Parrish 2009-04-27 14:38:45 EDT
Thank you for the bug report.  This issue needs to be addressed by the upstream developers.  Please submit a report at http://bugs.kde.org. You are requested to add the bugzilla link here for tracking purposes. Please make sure the bug isn't already in the upstream bug tracker before filing it.
Comment 9 Steven M. Parrish 2009-05-26 09:57:44 EDT
Closing this as INSUFFICIENT_DATA.  Please feel free to reopen once this issue has been reported UPSTREAM and you have additional information.

Note You need to log in before you can comment on or make changes to this bug.