Bug 486483 - GDM uses wrong keyboard layout after installation & update
GDM uses wrong keyboard layout after installation & update
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-19 18:13 EST by info@kobaltwit.be
Modified: 2015-01-14 18:22 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-20 23:19:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description info@kobaltwit.be 2009-02-19 18:13:29 EST
Description of problem:
My laptop's keyboard is equipped with a be-latin1 (azerty) keyboard. During a fresh install of F11 alpha I selected be-latin1 as my keyboard layout.
After the first login (immediately after the installation) I have updated the system to the most recent rawhide and rebooted.

From now on, upon login, gdm is using a querty layout even though the layout selection field shows be-latin1.
This can be changed by selecting another layout in the layout selection field. Among the posibilities is "Belgian".
Choosing "Belgian" fixes the problem, also on subsequent boots, but note that from now on the layout field shows "Belgian" instead of "be-latin1". So there seems to be a naming mismatch.

Version-Release number of selected component (if applicable):
gdm-2.25.2-3.fc11.i386

How reproducible:
Each time on a fresh install

Steps to Reproduce:
1. Fresh install of F11 alpha
2. During install, choose keyboard layout be-latin1
3. After installation, update everything to most recent rawhide
4. Restart
=> notice that the layout field in gdm shows "be-latin1"
5. Enter password that is azerty/querty sensitive
=> layout is querty
6. In the layout popup, select other and choose the Belgian layout
=> notice that from now on the layout field shows "Belgian"
7. Enter password again
=> notice that layout is azerty now

Additional info:
Gdm remembers the setting you choose in the layout field, so on subsequent logins the keyboard layout is correct. This seems to be a one-time issue upon installation.
I have experienced this on a Macbook Pro Core2 Duo, 2.16GHz. I mention this as that hardware is a bit exotic, it may be important to reproduce.
Comment 1 Matthias Clasen 2009-02-20 23:19:55 EST
Should be fixed in gdm-2.25.2-5

Note You need to log in before you can comment on or make changes to this bug.