Bug 486566 - Yum obsoletes processing does not work when the obsoleting package is already installed
Yum obsoletes processing does not work when the obsoleting package is already...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F11Target
  Show dependency treegraph
 
Reported: 2009-02-20 06:10 EST by Nicolas Mailhot
Modified: 2014-01-21 18:08 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-23 21:04:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2009-02-20 06:10:04 EST
Since rpm sadly allows the installation of an obsoleted package on a system that already includes the stuff obsoleting it (bug #486565), this situation needs to be handled by yum.

Unfortunately since the obsoleting package is already installed on system yum does not see the obsoleted package should be garbage collected and leaves it installed.

This should be fixed
yum-3.2.21-9.fc11.noarch
Comment 1 seth vidal 2009-02-20 08:25:18 EST
How did the obsoleted pkg get installed?
Comment 2 Nicolas Mailhot 2009-02-22 13:12:28 EST
This is bug #486565 rpm lets users install already obsoleted packages with rpm -Uvh without complaining at all
Comment 3 James Antill 2009-02-22 15:17:42 EST
Last I checked it worked on each update Eg.

1. pkgA obsoletes pkgB
2a. pkgA installed
2b. thus. pkgB removed
3. pkgB installed (yum localinstall will do this as well as rpm)
4a. pkgA updates
4b. thus. pkgB removed again

...if you are suggesting that 4b should happen without 4a, then I have to disagree. Also if you want conflict+obsoletes then do conflict+obsoletes.
Comment 4 Nicolas Mailhot 2009-02-22 15:48:16 EST
It works that way

1. pkgA obsoletes pkgB
2. pkgA installed
3. pkgB installed via rpm (user following an howto, package available on local disk, whatever)
4. yum update. yum sees pkgA installed, does not processes its obsolete info, and pkgB is never garbage collected
5. user complains his system is broken; investigation shows pkgB interferes with pkgA, and pkgA's maintainer relied on the package management tools to get rid of pkgB when pkgA is installed

Waitin for a pkgA update is no help as in can happen months/years later
Comment 5 James Antill 2009-02-23 21:04:48 EST
Which is what I said.

If pkgA _conflicts_ with pkgB as well as obsoleting it, then the specfile should say that. If rpm is changed to "auto conflict" on obsolete, then we'll make changes to yum to conform to that new world view ... until then, NoB.

Note You need to log in before you can comment on or make changes to this bug.