Bug 486589 - gnome-chemistry-utils mozilla plugin does not build against 1.9.1, help needed.
gnome-chemistry-utils mozilla plugin does not build against 1.9.1, help needed.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-chemistry-utils (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-20 09:05 EST by Julian Sikorski
Modified: 2009-02-24 10:03 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-24 08:39:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My futile attempt at patching the problem (1.65 KB, text/plain)
2009-02-20 09:07 EST, Julian Sikorski
no flags Details
the patch (2.11 KB, patch)
2009-02-24 08:39 EST, Martin Stransky
no flags Details | Diff

  None (edit)
Description Julian Sikorski 2009-02-20 09:05:49 EST
Description of problem:
Due to some changes in xulrunner-1.9.1, it is no longer possible to build the gnome chemistry utils mozilla plugin. In the mailing list, I was directed to
http://cvs.savannah.gnu.org/viewvc/classpath/native/plugin/gcjwebplugin.cc?root=classpath&r1=1.13&r2=1.14&diff_format=u
as an example of what needs to be adjusted. I tried to copy the necessary changes over, but since I can't code, I failed miserably:
http://belegdol.fedorapeople.org/build.log
The patch I ended up with is attached. Upstream tracker item is also available for reference:
http://savannah.nongnu.org/bugs/?25628
Help is very much appreciated, thank you in advance.
Please note that you need to use:
http://belegdol.fedorapeople.org/gnome-chemistry-utils-0.10.3-2.fc11.src.rpm
The version in cvs has still unsolved gcc-4.4 problems.
Comment 1 Julian Sikorski 2009-02-20 09:07:45 EST
Created attachment 332703 [details]
My futile attempt at patching the problem
Comment 2 Christopher Aillon 2009-02-23 11:27:25 EST
Martin, can you help?
Comment 3 Martin Stransky 2009-02-24 05:33:46 EST
Sure thing.
Comment 4 Martin Stransky 2009-02-24 08:39:05 EST
Added to gnome-chemistry-utils-0.10.3-3.fc11, please propagate the fix upstream. As for the fix, you need to move the HAVE_NPFUNCTIONS_H definition to config.h
Comment 5 Martin Stransky 2009-02-24 08:39:55 EST
Created attachment 333043 [details]
the patch
Comment 6 Martin Stransky 2009-02-24 08:50:29 EST
Looks like koji is busted now, need to rebuild later.
Comment 7 Julian Sikorski 2009-02-24 10:03:39 EST
It's not koji, some more adjustments need to be made. I'll handle it from here. Thanks a lot for the patch!

Note You need to log in before you can comment on or make changes to this bug.