Bug 486612 - External monitor doesn't work on ATI mobility radeon U1 (IGP 320M)
External monitor doesn't work on ATI mobility radeon U1 (IGP 320M)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-20 11:53 EST by Simone Marchioni
Modified: 2009-12-18 02:59 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 02:59:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg logfile (100.95 KB, text/plain)
2009-02-26 09:17 EST, Simone Marchioni
no flags Details

  None (edit)
Description Simone Marchioni 2009-02-20 11:53:48 EST
Description of problem:
Installed Fedora 10 on a Compaq Presario 2100 and updated to last packages.
The video card is functioning correctly on the integrated LCD monitor, but the external VGA output doesn't work.
The integrated video is an ATI Radeon Mobility U1 (IGP320M)

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati 6.0.0-2

How reproducible:
Always

Steps to Reproduce:
1. Connect an external CRT or LCD monitor
  
Actual results:
The notebook "feels" the external monitor connected (the screen resolution utility shows both the integrated LCD and the external monitor), but the screens shows "no input signal"

Expected results:
The external monitor should work

Additional info:
Tried 3 different LCD monitors and a CRT monitor but obtained the same result.
Comment 1 Simone Marchioni 2009-02-20 12:08:32 EST
Errata: the version of xorg-x11-drv-ati is 6.10.0-2
Comment 2 Matěj Cepl 2009-02-25 06:28:16 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Simone Marchioni 2009-02-26 09:17:27 EST
Created attachment 333330 [details]
Xorg logfile

Here's the X log.
There's no config file in /etc/X11
Comment 4 Steve Baker 2009-11-01 08:37:19 EST
Device info:
lspi-vv

01:05.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility U1 (prog-if 00 [VGA controller])
	Subsystem: Hewlett-Packard Company Pavilion ze4400 builtin Video
	Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping+ SERR- FastB2B+ DisINTx-
	Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Interrupt: pin A routed to IRQ 10
	Region 0: Memory at e0000000 (32-bit, prefetchable) [size=256M]
	Region 1: I/O ports at 9000 [size=256]
	Region 2: Memory at d0100000 (32-bit, non-prefetchable) [size=64K]
	[virtual] Expansion ROM at d0120000 [disabled] [size=128K]
	Capabilities: [58] AGP version 2.0
		Status: RQ=48 Iso- ArqSz=0 Cal=0 SBA+ ITACoh- GART64- HTrans- 64bit- FW- AGP3- Rate=x1,x2,x4
		Command: RQ=16 ArqSz=0 Cal=0 SBA+ AGP+ GART64- 64bit- FW- Rate=x4
	Capabilities: [50] Power Management version 2
		Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
	Kernel modules: radeon, radeonfb


Any resolution to this?

I have a similar problem on F11  
Exactly as describe in bug after the login to Gnome.
Prior to login I can see everything the laptop displays on the external monitor, once I login it goes black.

After fiddling with the different setting in Display Settings for the external monitor it suddenly starts working in Mirrored Mode. I believe what gets it working is the Left mode which I cancel then set to mirrored mode.
The lay out prior to mirrored mode is laptop on the Right external on the Left.
 

I have the xorg.config file
Comment 5 Bug Zapper 2009-11-18 06:10:30 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Bug Zapper 2009-12-18 02:59:12 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.