Bug 486616 - glibc upgrade conflict on x86_64
glibc upgrade conflict on x86_64
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-20 12:02 EST by Mace Moneta
Modified: 2014-01-21 18:08 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-06 15:58:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mace Moneta 2009-02-20 12:02:39 EST
Description of problem:

Unable to upgrade glibc.

Version-Release number of selected component (if applicable):

glibc-2.9.90-7

How reproducible:

Always

Steps to Reproduce:
1.yum update
2.
3.
  
Actual results:

Currently installed:
glibc-devel-2.9.90-3.x86_64
glibc-headers-2.9.90-3.x86_64
glibc-common-2.9.90-3.x86_64
glibc-2.9.90-3.x86_64
glibc-2.9.90-3.i386

yum update:
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package glibc.x86_64 0:2.9.90-7 set to be updated
---> Package glibc-common.x86_64 0:2.9.90-7 set to be updated
--> Processing Dependency: glibc-common = 2.9.90-3 for package: glibc
---> Package glibc-devel.x86_64 0:2.9.90-7 set to be updated
---> Package glibc-headers.x86_64 0:2.9.90-7 set to be updated
--> Finished Dependency Resolution
glibc-2.9.90-3.i386 from installed has depsolving problems
  --> Missing Dependency: glibc-common = 2.9.90-3 is needed by package glibc-2.9.90-3.i386 (installed)
--> Running transaction check
---> Package glibc-common.x86_64 0:2.9.90-7 set to be updated
--> Processing Dependency: glibc-common = 2.9.90-7 for package: glibc
--> Finished Dependency Resolution
glibc-2.9.90-7.x86_64 from rawhide has depsolving problems
  --> Missing Dependency: glibc-common = 2.9.90-7 is needed by package glibc-2.9.90-7.x86_64 (rawhide)
--> Running transaction check
---> Package glibc.x86_64 0:2.9.90-7 set to be updated
--> Processing Dependency: glibc = 2.9.90-7 for package: glibc-devel
--> Processing Dependency: glibc = 2.9.90-7 for package: glibc-headers
---> Package glibc-common.x86_64 0:2.9.90-7 set to be updated
--> Finished Dependency Resolution
glibc-headers-2.9.90-7.x86_64 from rawhide has depsolving problems
  --> Missing Dependency: glibc = 2.9.90-7 is needed by package glibc-headers-2.9.90-7.x86_64 (rawhide)
glibc-devel-2.9.90-7.x86_64 from rawhide has depsolving problems
  --> Missing Dependency: glibc = 2.9.90-7 is needed by package glibc-devel-2.9.90-7.x86_64 (rawhide)

Packages skipped because of dependency problems:
    glibc-2.9.90-7.x86_64 from rawhide
    glibc-common-2.9.90-7.x86_64 from rawhide
    glibc-devel-2.9.90-7.x86_64 from rawhide
    glibc-headers-2.9.90-7.x86_64 from rawhide

Expected results:

Successful update

Additional info:

PackageKit-yum-0.4.3-1.fc11.x86_64
PackageKit-yum-plugin-0.4.3-1.fc11.x86_64
rpm-4.6.0-5.fc11.x86_64
rpm-build-4.6.0-5.fc11.x86_64
rpm-libs-4.6.0-5.fc11.x86_64
rpm-python-4.6.0-5.fc11.x86_64
rpmrebuild-2.3-1.fc11.noarch
yum-3.2.21-9.fc11.noarch
yum-fastestmirror-1.1.19-1.fc11.noarch
yum-metadata-parser-1.1.2-11.fc11.x86_64
yum-utils-1.1.19-1.fc11.noarch
Comment 1 pgaltieri 2009-02-22 14:38:56 EST
A similar problem occurs for i386

[root@localhost ~]# yum -y update glibc-common
Loaded plugins: dellsysidplugin2, refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package glibc-common.i586 0:2.9.90-7 set to be updated
--> Processing Dependency: glibc = 2.9.90-7 for package: glibc-common
--> Processing Dependency: glibc-common = 2.9.90-2 for package: glibc
--> Running transaction check
---> Package glibc.i686 0:2.9.90-7 set to be updated
--> Processing Dependency: glibc-common = 2.9.90-2 for package: glibc
--> Finished Dependency Resolution
glibc-2.9.90-2.i386 from installed has depsolving problems
  --> Missing Dependency: glibc-common = 2.9.90-2 is needed by package glibc-2.9.90-2.i386 (installed)
Error: Missing Dependency: glibc-common = 2.9.90-2 is needed by package glibc-2.9.90-2.i386 (installed)

[root@localhost ~]# yum list installed | grep glibc-common
glibc-common.i386                       2.9.90-2                       installed

[root@localhost ~]# yum list all | grep glibc-common
glibc-common.i386                       2.9.90-2                       installed
glibc-common.i586                       2.9.90-7                       rawhide  

There does not appear to be an updated version of glibc-common for i386
Comment 2 Mace Moneta 2009-02-22 14:57:49 EST
I've worked around this manually on x86_64:

# rpm -e --nodeps glibc-2.9.90-3.i386
# yum install glibc.i586
# yum update

Now installed:

# rpm -qa | grep glibc
glibc-2.9.90-7.i586
glibc-headers-2.9.90-7.x86_64
glibc-common-2.9.90-7.x86_64
glibc-devel-2.9.90-7.x86_64
glibc-2.9.90-7.x86_64

Not sure if this is the recommended solution.
Comment 3 Michel Duquaine 2009-02-26 13:49:30 EST
Same kind of problem with i386 & Fedora Rawhide:

[root@test ~]# yum update
Loaded plugins: dellsysidplugin2, refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: glibc-common = 2.9.90-2 for package: glibc
---> Package glibc-common.i586 0:2.9.90-7 set to be updated
--> Processing Dependency: glibc = 2.9.90-7 for package: glibc-common
--> Running transaction check
---> Package glibc.i686 0:2.9.90-7 set to be updated
--> Processing Dependency: glibc-common = 2.9.90-2 for package: glibc
--> Finished Dependency Resolution
glibc-2.9.90-2.i386 from installed has depsolving problems
  --> Missing Dependency: glibc-common = 2.9.90-2 is needed by package glibc-2.9.90-2.i386 (installed)
Error: Missing Dependency: glibc-common = 2.9.90-2 is needed by package glibc-2.9.90-2.i386 (installed)
Comment 4 pgaltieri 2009-02-26 14:47:07 EST
Here's how I worked around the problem.

yumdownloader glibc.i586 glibc-common.i586

rpm -Uvh glibc*

The first command downloads the glibc rpm's to the local directory.  The second command updates the glibc version.  Trying to do an rpm -i glibc* will result in conflicts.  Doing an update seems to work.  Afterwards I did

yum -y update

and all the packages updated without problems
Comment 5 Michel Duquaine 2009-02-27 12:58:08 EST
I executed the workaround from pgaltieri (comment #4) and it is ok. Thanks!
Comment 6 seth vidal 2009-03-06 09:53:10 EST
can you still test this and test the solution in comment:

https://bugzilla.redhat.com/show_bug.cgi?id=488224#c4
Comment 7 seth vidal 2009-03-06 15:58:17 EST
nevermind.

This bug is a result of glibc being one of the 'exactarchlist' packages.

rawhide will soon have a package to fix this problem or you can edit your yum.conf and under [main] put:
exactarchlist = kernel


and it will work.

closing as upstream

Note You need to log in before you can comment on or make changes to this bug.