Bug 48662 - Problem with graphics blaster exxtreme dispaly card in Xwindows
Problem with graphics blaster exxtreme dispaly card in Xwindows
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-11 01:36 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-25 13:12:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-07-11 01:36:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
The card used to work fine till the version 6.3 of Linux but from 7.0
onwards it is difficult to configure it at colour depths above 8 bit and if
it does happen then the colour spills over at 16bit( excess of yellow) and
in 24 bit the display becomes garbled at teh area of activity on the screen
the monitor used is Viewsonic E-40. A number of others with the same card
have reported the prob;em too.

How reproducible:
Always

Steps to Reproduce:
1.run setup at the command prompt	
and configure the video card with auto probe and specify monitor type
2 select the colour depth of 24 bit /16 bit and the display will be
configured but it will be gharbled when actually used by logging in to
Gnome.
3.
	

Actual Results:  The card could not be configured	

Expected Results:  The sard should have been configured at 16 bit at a
resolution of 800*600 as it used to in the 6.3 version of Linux

Additional info:
Comment 1 Mike A. Harris 2001-07-12 11:15:34 EDT
We have never shipped a version 6.3 of Red Hat Linux.  If you are using 
a version 6.3, it is definitely not Red Hat Linux.

In order to investigate this, I will need to know exactly what video
hardware you have.  There are too many brand names to know what all chipsets
they use.  Please attach a copy of your XFree86 server logs and configuration
file as uncompressed file attachments using the link below and I will see if
I can help you.

Thanks
Comment 2 Need Real Name 2001-07-12 12:42:18 EDT
Sir
I apologise for a mistake on my part and it was the incorrect mention of the 
earlier version of Redhat Linux and it should rather be versions 
6.0,6.1&6.2,actually the original configuration of teh PC carried the SIS 6326 
graphics card which did not find supprot in Linux (redhat) 6.0 so i changed it 
to Graphics Blaster exxtreme manufactured by Creative labs wit h4 MB of video 
RAM and the chipset detected by probe is PErmedia2(glint). In fact during the 
past 3 hours or so the problem assumed such proportions that i had to remove 
version 7.1 from my system and downgrade it to 6.0 so the log report of 7.1 
would not be possible for now but if it cannot be dispensed with then i will 
once again install and generate the report. And if the 6.0 log can serve teh 
purpose then please tell the procedure of generating such a report.
The problem became so severe that the system started to go into suspend mode 
without any prior warning, so had to take teh extreme step.
Comment 3 Need Real Name 2001-07-18 11:50:09 EDT
Sir 
the problem mentioned above could be solved by selecting the generic driver (3D
labs)for the graphics card during the installation in low resoluton mode, so the
solution may be archived for further queries in the same context
Sudhendu
Comment 4 Mike A. Harris 2001-07-25 13:12:52 EDT
This problem with the permedia chips I believe should be fixed in
XFree86 4.0.3-24 at:

ftp://people.redhat.com/mharris/testing/7.1
Please try it, and update the report to reflect the results.
Comment 5 Mike A. Harris 2001-10-22 01:43:11 EDT
Resolving bug assuming it is fixed due to lack of feedback,
and no bad reports coming in from anyone else.
XFree86-4.1.0-3 is the current release.

Note You need to log in before you can comment on or make changes to this bug.