This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 486640 - Can't Attach Additional Document to an HTML MailMerge
Can't Attach Additional Document to an HTML MailMerge
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-20 14:56 EST by Eli Wapniarski
Modified: 2009-02-23 06:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-23 06:00:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 99522 None None None Never

  None (edit)
Description Eli Wapniarski 2009-02-20 14:56:30 EST
Hi

I will be making several Feature Enhancement Requests and Bug Reports born of sincere desperation. About the only reason that I use a word processor is to work on my resume and send it out via mailmerge. I had no problem with StarOffice 5.2, but that was years ago and of course it doesn't no longer work under Linux so, as you can imagine I've got a work around by installing SO 5.2 under Windows in a Virtual Machine. Which of course is not the way I want to go.

So here goes:

Feature Request 1

It would be really great if I could attach document to mailmerge to an HTML document.
Comment 1 Caolan McNamara 2009-02-22 18:16:35 EST
I'm pretty sure that StarOffice 5.2 didn't have a mailmerge component.

In F-10, install openoffice.org-emailmerge, open the document you want to send to via mailmerge, use tools->mail merge wizard, and at what stage are you unable to achieve what it is what you want to do ?
Comment 2 Eli Wapniarski 2009-02-23 00:51:31 EST
So 5.2 has a very good mailmerge component. It worked better under Linux then under Windows. Under Windows attaching a file garbles up the file name.

I wouldn't be making the request if I didn't try to use the mail wizard feature.

Do I really have to QA this a gazillion times. Mailmerge to email HTML encoded email simply does not work.

This particular feature request blow by blow. I will assume that a document has been created and an address database has been attached to the document and is open


Tools -> MailMerge -> Use the current document -> Next

E-mail message -> Next

Select Address List (Select the Address database and table that you want
Filter if you want to by click on filter) -> Next

(Create a salutation if you want to) -> Next

(Preview and edit the document if you want to) -> Next

(Personalize the mail merge) -> Edit individual document -> Scroll down the document and records in the database are in the document in table form ready to be sent along with the document (Note: this could be a result of filtering since before I make myself look silly I need to check if things look OK so I'm sending a mailmerge email to myself). -> Next

Send merged document as E-Mail 
Select the field containing the email addresses in the To drop down list
Type in Your Subject
Send all documents or From 1 to 1. (Note: there is no option to send "selected records" like in so5.2 and there is no option it attach a file which is useful since the email should have a salutation. A file lets say in odt or doc format should not necessarily contain a salutation.

Please forgive me if I seem a little edgy. But I just got let go of my job. I need to do some job hunting and the only efficient way to do this in the contemporary world is via personalized email which means a well crafted salution built into the document personalized data in a database and compiled under mailmerge. Voila 1000 emails sent in a couple of hours. 

Pulease... the last time I did this I used so 5.2 under Linux. Currently there is no working productivity suite option under Linux and using wine only provides a partial solution. So right now... In order to avoid doing any work on a Windows comptuer because I do not have a license for Windows or MS Office. I'm now starting to look at mailing list software. Really this should have been available a long time ago. This really is an extremely important core feature and should have been QAed much much better than it was.

If you want to look at how so52 did I can find probably find a link to download the software. While it won't run natively under Linux the Windows version does run under Wine.

Please please please help. This (at least for me is trully trully important).
Comment 3 Caolan McNamara 2009-02-23 04:17:51 EST
Using html message uses the document you've created as the *body* of the email message, i.e. creates a html email from it. Why not instead of selecting "html message" select a different format, e.g. "Microsoft Office" or "OpenDocument", which sends the document as an *attachment*. That then enables the "properties" button, and that dialog allows an email built up from the available fields (which can be further customized) to be created to send along with the document. That sounds more like what you want to do.
Comment 4 Eli Wapniarski 2009-02-23 04:39:54 EST
What I want to do is to send a nicely formatted email (html) which includes a copy of my resume and attached to that is a word file (living with reality) of my resume.

If I send that email built from available fields the person doesn't see that until they open the word doc.

Why don't I use the custom salution because it is text only and extemely cumbersome to use in the current format.
Comment 5 Caolan McNamara 2009-02-23 06:00:18 EST
Yeah, it would be better to be able to add arbitrary additional attachment when sending the final emails. Moving upstream as http://qa.openoffice.org/issues/show_bug.cgi?id=99522
Comment 6 Eli Wapniarski 2009-02-23 06:14:00 EST
Thank you very much.

Note You need to log in before you can comment on or make changes to this bug.