Bug 486641 - library dependency issues
Summary: library dependency issues
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pango
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Behdad Esfahbod
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-02-20 20:01 UTC by Orion Poplawski
Modified: 2009-03-26 04:09 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-03-26 04:09:24 UTC
Type: ---


Attachments (Terms of Use)

Description Orion Poplawski 2009-02-20 20:01:48 UTC
Description of problem:

rpmlint pango
pango.i386: E: explicit-lib-dependency libX11
pango.i386: E: explicit-lib-dependency libXext
pango.i386: E: explicit-lib-dependency libXft
pango.i386: E: explicit-lib-dependency libXrender
pango.i386: W: unused-direct-shlib-dependency /usr/lib/libpangoxft-1.0.so.0.2300.0 /lib/libgmodule-2.0.so.0
pango.i386: W: unused-direct-shlib-dependency /usr/lib/libpangoxft-1.0.so.0.2300.0 /usr/lib/libfreetype.so.6
pango.i386: W: unused-direct-shlib-dependency /usr/lib/libpangoft2-1.0.so.0.2300.0 /lib/libgmodule-2.0.so.0
pango.i386: W: unused-direct-shlib-dependency /usr/lib/libpangox-1.0.so.0.2300.0 /lib/libm.so.6
pango.i386: W: unused-direct-shlib-dependency /usr/lib/libpangox-1.0.so.0.2300.0 /lib/libgmodule-2.0.so.0
pango.i386: W: unused-direct-shlib-dependency /usr/lib/libpangocairo-1.0.so.0.2300.0/lib/libgmodule-2.0.so.0

Version-Release number of selected component (if applicable):
pango-1.23.0-2.fc11.i386

Comment 1 Behdad Esfahbod 2009-03-26 04:09:24 UTC
* Wed Mar 26 2009 Behdad Esfahbod <besfahbo@redhat.com> - 1.24.0-2
- Remove weird Requires(pre).
- Resolves #486641


Note You need to log in before you can comment on or make changes to this bug.