Bug 486681 - Can't change menu items
Can't change menu items
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lxpanel (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-20 19:05 EST by Justin Zygmont
Modified: 2009-08-07 01:02 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.4.1-2.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-25 18:42:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Zygmont 2009-02-20 19:05:50 EST
Description of problem:

From: Preferences -> Menu   

Changes made dont seem to take effect when in LXDE, when going back to gnome however, it does show the changes.  I'm doing this as root too.


Version-Release number of selected component (if applicable):

Fedora 10 (updates all applied)
lxde-common-0.3.2.1-3.fc10.i386  the latest



How reproducible:

always 


Steps to Reproduce:
1. Click on F in the bottom left part of the screen
2. Select Perferences -> Menu and make any changes to the menus
3. Save, exit, reboot, etc.  Changes dont take effect.
  
Actual results:


Expected results:


Additional info:
Comment 1 Christoph Wickert 2009-02-22 20:14:07 EST
Preferences -> Menu
is alacarte, which only works for Gnome. I have filed bug # 486887 to remove it from the menus of other desktops.

LXPanel does not support menu merging (just like Xfce), so the only way to edit the menus as similar to this Howto:
http://wiki.xfce.org/howto/customize-menu

Menu editing will become better with lxpanel-0.4.0, but it' still not working properly in the latest beta 2 version. Needs still work because LXDE was added to the freedesktop.org specs just a few weeks ago.
Comment 2 Christoph Wickert 2009-02-25 18:42:13 EST
After testing lxpanel 0.3.999 I have sad news: It also does not support merging, so the only was to edit menus is the one described in the Xfce wiki.

Sorry, there is nothing I could do for you. Closing.
Comment 3 Christoph Wickert 2009-04-27 09:13:24 EDT
Good news: LXPanel 0.4.0 indeed does menu merging and the menu can be edited with alacarte.

Bad news: We are not planing to release this version in F-10, but packages are available for F-11 and rawhide. Feel free to try them, but you will also need menu-cach 0.24 and lxmenu-data.
Comment 4 Justin Zygmont 2009-04-27 09:26:15 EDT
(In reply to comment #3)
> Good news: LXPanel 0.4.0 indeed does menu merging and the menu can be edited
> with alacarte.
> 
> Bad news: We are not planing to release this version in F-10, but packages are
> available for F-11 and rawhide. Feel free to try them, but you will also need
> menu-cach 0.24 and lxmenu-data.  


Thats good to know, and it has been fine the way it is too.  I like the efficiency of LXDE a lot and its worked very well all this time.
Comment 5 Sebastian Vahl 2009-04-28 04:06:16 EDT
(In reply to comment #3)
> Bad news: We are not planing to release this version in F-10, but packages are
> available for F-11 and rawhide. Feel free to try them, but you will also need
> menu-cach 0.24 and lxmenu-data.  

Well, why not? If there are no regressions (and no problems with menu-cache or lxmenu-data in f10), I don't know why not to do so.
Comment 6 Christoph Wickert 2009-04-29 11:27:49 EDT
OK, but let's wait until F-11 has landed. I have some update waiting for F-11, so I can't push the packages for F-10 without breaking the upgrade path. When the dust has settled, we do a update for lxpanel built against the latest menu-cache and lxmenu-data.
Comment 7 Fedora Update System 2009-07-24 23:02:46 EDT
lxpanel-0.4.1-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/lxpanel-0.4.1-2.fc10
Comment 8 Fedora Update System 2009-08-07 01:02:55 EDT
lxpanel-0.4.1-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.