Bug 486682 - Kernel mode settings makes i810 sluggish and unusable.
Kernel mode settings makes i810 sluggish and unusable.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks: IntelKMS
  Show dependency treegraph
 
Reported: 2009-02-20 19:05 EST by Craig Robson
Modified: 2009-04-27 11:28 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-13 14:56:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg.0.log (41.74 KB, text/plain)
2009-02-24 09:54 EST, Ralf Ertzinger
no flags Details
Xorg.0.conf with nomodeset kernel command (101.32 KB, text/plain)
2009-02-24 10:06 EST, Ralf Ertzinger
no flags Details
Log with kernel mode setting (21.30 KB, text/plain)
2009-02-24 10:48 EST, Craig Robson
no flags Details
Xorg.0.log with nomodeset (128.05 KB, text/plain)
2009-02-24 10:49 EST, Craig Robson
no flags Details

  None (edit)
Description Craig Robson 2009-02-20 19:05:55 EST
When I upgrade to the kernel-PAE-2.6.29-0.124.rc5.fc11.i686 and kernel-PAE-2.6.29-0.131.rc5.git2.fc11.i686 the display performance became sluggish.

I assume this is cause by this kernel mode setting:

* Mon Feb 16 2009 Kristian Høgsberg <krh@redhat.com>
- Flip the switch on intel KMS.


This is on a Thinkpad X60.
Comment 1 Craig Robson 2009-02-20 19:30:54 EST
I have verified that disabling mode setting via nomodeset kernel option makes this problem go away.
Comment 2 Sven Lankes 2009-02-22 07:23:10 EST
Same here. Running with nomodeset, top shows ~320 MB allocated virtual memory - running with modesetting enabled, this increases to ~2000 MB.

I'm seeing this on a Toshiba Netbook with Intel 945GM Chipset.
Comment 3 Sven Lankes 2009-02-22 07:28:42 EST
The issue seems to be chipset-specific - on a 2nd machine with a G35 chipset
kms works smooth and without issues.

Working:

00:02.0 VGA compatible controller: Intel Corporation 82G35 Express Integrated Graphics Controller (rev 03)

Broken: 

00:02.1 VGA compatible controller: Intel Corporation Mobile 945GME/GMS/GME, 943/940ML Express Integrated Graphics Controller (rev 03)
Comment 4 Matěj Cepl 2009-02-24 09:25:42 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config files (/etc/X11/xorg.conf, if available) and X server log files (/var/log/Xorg.*.log) from running both with and without nomodeset setting on to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 5 Kristian Høgsberg 2009-02-24 09:35:59 EST
(In reply to comment #3)
> The issue seems to be chipset-specific - on a 2nd machine with a G35 chipset
> kms works smooth and without issues.
> 
> Working:
> 
> 00:02.0 VGA compatible controller: Intel Corporation 82G35 Express Integrated
> Graphics Controller (rev 03)
> 
> Broken: 
> 
> 00:02.1 VGA compatible controller: Intel Corporation Mobile 945GME/GMS/GME,
> 943/940ML Express Integrated Graphics Controller (rev 03)

Are you running PAE kernels on both machines?
Comment 6 Ralf Ertzinger 2009-02-24 09:52:12 EST
I see this (Thinkpad X60s / 945GME), and yes, I do run a PAE kernel.

Xorg.0.log attached.
Comment 7 Ralf Ertzinger 2009-02-24 09:54:53 EST
Created attachment 333047 [details]
Xorg.0.log
Comment 8 Ralf Ertzinger 2009-02-24 10:06:57 EST
Created attachment 333049 [details]
Xorg.0.conf with nomodeset kernel command
Comment 9 Sven Lankes 2009-02-24 10:20:33 EST
(In reply to comment #5)

>> Working:
>> 00:02.0 VGA compatible controller: Intel Corporation 82G35 Express Integrated
>> Graphics Controller (rev 03)
>> Broken: 
>> 00:02.1 VGA compatible controller: Intel Corporation Mobile 945GME/GMS/GME,
>> 943/940ML Express Integrated Graphics Controller (rev 03)
 
> Are you running PAE kernels on both machines?

Nope. The working one is running x86_64, broken is running a 32-bit PAE-Kernel.
Comment 10 Craig Robson 2009-02-24 10:48:22 EST
Created attachment 333053 [details]
Log with kernel mode setting
Comment 11 Craig Robson 2009-02-24 10:49:06 EST
Created attachment 333054 [details]
Xorg.0.log with nomodeset
Comment 12 Craig Robson 2009-02-24 10:52:55 EST
I attached the Xorg.0.log with and kernel mode setting on and off.

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

I am currently running kernel 2.6.29-0.137.rc5.git4.fc11.i686.PAE

It looks like Xorg memory usage goes way up as soon as I open several firefox windows.
Comment 13 Craig Robson 2009-02-24 10:54:22 EST
There is no xorg.conf for this machine it is being completely autogenerated.
Comment 14 Craig Robson 2009-03-02 21:54:45 EST
This seems to be fixed in the latest rawhide.  xorg-x11-drv-intel-2.6.0-10.fc11.i586.

Note You need to log in before you can comment on or make changes to this bug.