This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 486722 - ypbind script in dos format - bash syntax errors
ypbind script in dos format - bash syntax errors
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ypbind (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-21 08:09 EST by John Ellson
Modified: 2009-02-26 10:17 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-26 10:17:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2009-02-21 08:09:27 EST
Description of problem:

root@ontap:~# service network restart
Shutting down interface eth0:                              [  OK  ]
Shutting down loopback interface:                          [  OK  ]
Bringing up loopback interface:                            [  OK  ]
Bringing up interface eth0:  
: command not foundrmation for eth0.../etc/dhcp/dhclient.d/nis.sh: line 23: 
: command not foundd/nis.sh: line 25: 
'etc/dhcp/dhclient.d/nis.sh: line 26: syntax error near unexpected token `{
'etc/dhcp/dhclient.d/nis.sh: line 26: `save_config_file() {
 done.
                                                           [  OK  ]

The problem is that /etc/dhcp/dhclient.d/nis.sh is a DOS formatted file, which produces bash syntax errors.

Version-Release number of selected component (if applicable):
ypbind-1.20.4-14.fc11.x86_64

How reproducible:
100%

Steps to Reproduce:
1. /etc/dhcp/dhclient.d/nis.sh
2.
3.
  
Actual results:
-bash: /etc/dhcp/dhclient.d/nis.sh: /bin/bash^M: bad interpreter: No such file or directory


Expected results:
no syntax errors

Additional info:
can be fixed with: 
    dos2unix /etc/dhcp/dhclient.d/nis.sh
Comment 1 Vitezslav Crhonek 2009-02-26 10:17:15 EST
Thank you for report, fixed in ypbind-1.20.4-16.fc11.

Note You need to log in before you can comment on or make changes to this bug.