Bug 486768 - connectathon test5 failing when run against rhel4 server
connectathon test5 failing when run against rhel4 server
Status: CLOSED DUPLICATE of bug 517162
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.8
All Linux
low Severity medium
: rc
: ---
Assigned To: Jeff Layton
Red Hat Kernel QE team
cthon09
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-21 20:31 EST by Jeff Layton
Modified: 2010-03-29 08:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-29 08:49:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
binary capture showing the problem packet in frame 1716 (1.26 MB, application/octet-stream)
2009-02-21 20:31 EST, Jeff Layton
no flags Details

  None (edit)
Description Jeff Layton 2009-02-21 20:31:40 EST
Created attachment 332835 [details]
binary capture showing the problem packet in frame 1716

To reproduce:

# mount -t nfs4 rhel4-server:/export /mnt/cthon
# cd /mnt/cthon
# env NFSTESTDIR=`pwd` /root/cthon04/basic/test5 -s
/root/cthon04/basic/test5: read and write
	/root/cthon04/basic/test5: (/mnt/cthon/redhat-11.test) can't create 'bigfile' : Input/output error

...after this, the directory FH goes stale:

# ls
ls: cannot open directory .: Stale NFS file handle

...the problem seems to be that after an open, we try to do a setattr on the file and the client is sending a bogus stateid (zeroed out).
Comment 1 Jeff Layton 2009-02-21 20:39:28 EST
I only see this problem when the test is run from recent clients. A RHEL5 client didn't trigger it. So I think the issue is that the client is now sending a zero stateid for this SETATTR call and older clients didn't. The server is throwing back an error, but according to the CITI guys it probably shouldn't be.

I'll have to verify this in the RFC...
Comment 2 Jeff Layton 2010-03-29 08:49:20 EDT

*** This bug has been marked as a duplicate of bug 517162 ***

Note You need to log in before you can comment on or make changes to this bug.