This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 486787 - Add whois server for .lc (we're lacking that TLD completely)
Add whois server for .lc (we're lacking that TLD completely)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: jwhois (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-21 22:55 EST by Robert Scheck
Modified: 2009-02-27 05:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-27 05:11:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2009-02-21 22:55:39 EST
Description of problem:
Please add a whois server for .lc, currently /etc/jwhois.conf doesn't mention 
any for this TLD. I'm aware, that http://www.iana.org/domains/root/db/lc.html
from IANA doesn't list any, but if you look to that site, the authoritative
DNS servers are from Afilias and in fact, Afilias is the technical contact and
provides the technical equipment for the .lc registry - so let's use a whois
server there which even works as expected.

Version-Release number of selected component (if applicable):
jwhois-4.0-10

How reproducible:
Everytime, whois query fails.

Actual results:
# whois nic.lc
[Querying whois.internic.net]
[whois.internic.net]
[...]
#

Expected results:
Add the following line in /etc/jwhois.conf after "\\.lb$" and everything works:

  "\\.lc$" = "whois2.afilias-grs.net";

Because:

# whois -h whois2.afilias-grs.net nic.lc
[Querying whois2.afilias-grs.net]
[whois2.afilias-grs.net]
[...]
#

Additional info:
Please try to get this fix upstream - upstream is unluckily always very very
unresponsive to me.

Note You need to log in before you can comment on or make changes to this bug.